Darkice gethostbyname error Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
pennywise89
Posts: 2
Joined: Wed Aug 19, 2020 8:21 pm

Darkice gethostbyname error

Post by pennywise89 »

Hi All,
I installed darkice+icecast from dietpi-software, but darkice won't attach to icecast2.

Steps to reproduce:

Code: Select all

sudo dietpi-software reinstall 135
sudo darkice
leads to..
DarkIce: TcpSocket.cpp:226: gethostbyname error [0]

my darkice.cfg is:

Code: Select all

[general]
duration      = 0
bufferSecs    = 3
reconnect     = yes

[input]
device        = hw:1,0
sampleRate    = 44100
bitsPerSample = 16
channel       = 1

[icecast2-0]
bitrateMode   = vbr
format        = vorbis
quality       = 0.8
server        = dietpi
port          = 8000
password      = dietpi
mountPoint    = DietPi
name          = DietPi
description   = DarkIce on DietPi
url           = http://localhost
genre         = none
public        = no
#localDumpFile = /mnt/dietpi_userdata/darkice_recording.ogg
Given the error about hostname, I looked at /etc/hosts but it seems okay...

Code: Select all

cat hosts

127.0.0.1 localhost
127.0.1.1 pi
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
Icecast2 is working fine on port 8000.... Device is a raspberry Pi B3+ running DietPi v6.34.3.

I've explored basically every google result trying to troubleshoot this and stumped. Any thoughts?
pennywise89
Posts: 2
Joined: Wed Aug 19, 2020 8:21 pm

Re: Darkice gethostbyname error

Post by pennywise89 »

Finally got this to work by uninstalling both icecast and darkice, then reinstalling them manually (apt-get install darkice, apt-get icecast2), then trying a few configurations until it worked. Not sure why the default dietpi install didn't work but overcame..
Post Reply