135 on OrangePi Lite working

Suggestions for features and software you would like to see in DietPi, goes here.
Post Reply
wh_hsn

135 on OrangePi Lite working

Post by wh_hsn »

Hi Dan,

I've just tried 135 today & it kind of worked a little bit better :)

I set the dietpi.txt file with y WiFi settings:

Code: Select all

# >> Networking Options -----------------------------
#If both Ethernet and Wifi are enabled, Wifi will take priority and Ethernet will be disabled.
#   1=enabled
Ethernet_Enabled=1
Wifi_Enabled=1

#Enter your Wifi details below, if applicable (Case Sensitive).
Wifi_SSID=MY_SSID
Wifi_KEY=MY_WIFI_KEY

#Enter your Static Network details below, if applicable.
Use_Static=1
Static_IP=192.168.1.100
Static_Mask=255.255.255.0
Static_Gateway=192.168.1.1
Static_DNS=8.8.8.8
The installation went ok & so as the update & reboot - previous version had a bug here that disabled wifi - in 135 this is corrected & extra software installation goes ok.
After second reboot the wifi was not working again.
I manually configured it by:

1- Editing /etc/modules (using a working file from Armbian installation - mainly using the right driver "8189fs"):

Code: Select all

8189fs
#gpio_sunxi
#w1-sunxi
#w1-gpio
#w1-therm
#gc2035
#vfe_v4l2
sunxi-cir
g_serial
2- Editing /etc/network/interfaces (DHCP):

Code: Select all

auto lo
iface lo inet loopback
auto wlan0
iface wlan0 inet dhcp
wpa-ap-scan 1
pre-up sudo /sbin/wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -Dnl80211 -B
pre-up sleep 5
post-down sudo killall -q wpa_supplicant
or (static):

Code: Select all

auto lo
auto wlan0
iface lo inet loopback
iface wlan0 inet static
address 192.168.1.100
netmask 255.255.255.0
gateway 192.168.1.1
pre-up sudo /sbin/wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -Dnl80211 -B
pre-up sleep 5
post-down sudo killall -q wpa_supplicant
3- Creating the file /etc/wpa_supplicant.conf using:

Code: Select all

wpa_passphrase "MY_SSID" "MY_KEY" > /etc/wpa_supplicant.conf 
The result will be:

Code: Select all

network={
	ssid="MY_SSID"
	#psk="MY_KEY"
	psk=ENCRIPTED_KEY_FROM_RUNNING_
}
Reboot & the board wifi is working.
Post Reply