RDP Black Screen Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
danmo117
Posts: 8
Joined: Wed Jun 03, 2020 4:01 pm

RDP Black Screen

Post by danmo117 »

Hi all, I know this has been asked before and I've tried loads of different "solutions" but I'm still experiencing an issue.

So I've got dietpi 6.30 installed on a Pi3b+ and it's usually managed via SSH however for some reason I can't get RDP to work. I know VNC has been mentioned but I manage multiple machines and use RDP for all of them so I'd like to do the same with my Pi.

From dietpi-software I installed XRDP which subsequently installs LXDE and TigerVNC as part of the process.
When I try to connect to the Pi using the official RDP client for Mac it opens with a black screen and if I leave it for a few minutes the attached message is displayed.

Does anyone know how to fix this?
Attachments
Screenshot 2020-06-03 at 15.35.58.png
User avatar
Joulinar
Posts: 2068
Joined: Sat Nov 16, 2019 12:49 am

Re: RDP Black Screen

Post by Joulinar »

Hi,

many thanks for your report. What did you select on the login screen for session? Do you use Xvnc? Looks like you are using Xorg.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
danmo117
Posts: 8
Joined: Wed Jun 03, 2020 4:01 pm

Re: RDP Black Screen

Post by danmo117 »

Joulinar wrote: Wed Jun 03, 2020 5:39 pm Hi,

many thanks for your report. What did you select on the login screen for session? Do you use Xvnc? Looks like you are using Xorg.
Hi Joulinar,

Thanks for getting back to me.

So you know all the steps.... I initiate the RDP connection and I instantly hit an all black screen, then after a few mins I get the aforementioned message in the screenshot. If I click OK on the message it takes me to the XRDP login page where I can select different session options.

If I select the default "Xorg" and input my login credentials I just get a blank teal colour and after a few minutes I get the same message screenshot in the OP.

My other session options are;
- Xvnc
- vnc-any
- neutrinordp-any

If I select Xvnc I get message attached.

In dietpi-config > AutoStart Options it's current set to number 2 (Desktops - automatic login), does this need to adjusted to anything else? Before tinkering with RDP it was set to 0 (Local Terminal - Manual Login) as I only accessed via SSH.
Attachments
Screenshot 2020-06-03 at 17.37.44.png
User avatar
Joulinar
Posts: 2068
Joined: Sat Nov 16, 2019 12:49 am

Re: RDP Black Screen

Post by Joulinar »

Autostart option can be set to 0 : Manual login (default) . No need to have it set to something else. Even on my test it was not switched and still set to 0. Furthermore VNC is running on a different port than xrdp expects. Let's check

Code: Select all

cat /boot/dietpi.txt | grep SOFTWARE_VNCSERVER_DISPLAY_INDEX
cat /etc/xrdp/sesman.ini | grep X11DisplayOffset=
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
danmo117
Posts: 8
Joined: Wed Jun 03, 2020 4:01 pm

Re: RDP Black Screen

Post by danmo117 »

Joulinar wrote: Wed Jun 03, 2020 7:22 pm Autostart option can be set to 0 : Manual login (default) . No need to have it set to something else. Even on my test it was not switched and still set to 0. Furthermore VNC is running on a different port than xrdp expects. Let's check

Code: Select all

cat /boot/dietpi.txt | grep SOFTWARE_VNCSERVER_DISPLAY_INDEX
cat /etc/xrdp/sesman.ini | grep X11DisplayOffset=
Thanks for confirming, I've set the auto start option back to 0.

As for the other checks.

SOFTWARE_VNCSERVER_DISPLAY_INDEX=1
X11DisplayOffset=10

Anything else I can check?
User avatar
Joulinar
Posts: 2068
Joined: Sat Nov 16, 2019 12:49 am

Re: RDP Black Screen

Post by Joulinar »

ok let's try to pin xrdp to use correct vnc port

Code: Select all

nano /etc/xrdp/xrdp.ini
down, close to the bottom you will find [Xvnc] section. change port=-1 to port=5901. Once done safe the file and restart xrdp

Code: Select all

systemctl restart xrdp.service
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
danmo117
Posts: 8
Joined: Wed Jun 03, 2020 4:01 pm

Re: RDP Black Screen

Post by danmo117 »

Joulinar wrote: Thu Jun 04, 2020 12:02 am ok let's try to pin xrdp to use correct vnc port

Code: Select all

nano /etc/xrdp/xrdp.ini
down, close to the bottom you will find [Xvnc] section. change port=-1 to port=5901. Once done safe the file and restart xrdp

Code: Select all

systemctl restart xrdp.service
Hi Joulinar, I've completed these steps however I'm still experiencing the same symptoms. :(
User avatar
Joulinar
Posts: 2068
Joined: Sat Nov 16, 2019 12:49 am

Re: RDP Black Screen

Post by Joulinar »

are you able to get the selection menu where you can choose xvnc?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
danmo117
Posts: 8
Joined: Wed Jun 03, 2020 4:01 pm

Re: RDP Black Screen

Post by danmo117 »

Joulinar wrote: Thu Jun 04, 2020 12:38 am are you able to get the selection menu where you can choose xvnc?
Apologies, I'd not removed the "-" from the port number so it stated "=-5901". I've since rectified this and I was able to see the desktop using the Xvnc option from the Xrdp login page.

I still have the black screen issue after the initial connection and I seemingly have to wait for the default connection method to time out (which is about 5 minutes) before I can see the Xrdp login page.

Please can you advise how to adjust the default connection method so I don't have the black screen issue, and out of curiosity why does the Xorg option not work?

Edit,

After running through the recreation steps once more, I now cannot access via Xvnc when I could only a few minutes ago. I've changed no settings in that time and the password is 100% correct. See screenshot.

Your time is appreciated.

Thanks.
Attachments
Screenshot 2020-06-04 at 09.13.03.png
User avatar
Joulinar
Posts: 2068
Joined: Sat Nov 16, 2019 12:49 am

Re: RDP Black Screen

Post by Joulinar »

Hi,

ok let's try to sort the topics
  1. You need to use Xvnc because you are trying to connect to a VNC server (TigerVNC) ;)
  2. You are not able to reconnect because you are hit by a Debian Bug
    1. https://bugs.debian.org/cgi-bin/bugrepo ... bug=932499
    2. https://github.com/TigerVNC/tigervnc/issues/800
    3. As far as I have seen some bugfix was created 2 days ago. But I don't know how log it will take before reaching the Debian software package
    4. However there is a workaround described on the Debian Bug tracker

      Code: Select all

      nano /usr/local/bin/vncserver
      Adjust following line by adding LD_PRELOAD=/lib/arm-linux-gnueabihf/libgcc_s.so.1

      Code: Select all

      $BINARY_FP :${DISPLAY:-1} -geometry ${WIDTH:-1280}'x'${HEIGHT:-720} -depth ${DEPTH:-16} || exit 1
      like this

      Code: Select all

      LD_PRELOAD=/lib/arm-linux-gnueabihf/libgcc_s.so.1 $BINARY_FP :${DISPLAY:-1} -geometry ${WIDTH:-1280}'x'${HEIGHT:-720} -depth ${DEPTH:-16} || exit 1
      
      save the file and restart the VNC server

      Code: Select all

      systemctl restart vncserver.service
  3. currently I don't know why you a running into the initial 5 minutes timeout. For me it looks like that your xrdp is trying to connect right from the beginning to a Xorg session. But usually it should display the selection screen first. :? Even on my test I was not able to replicate this behaviour.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply