dietpi-update/apt-get update Error Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
bambusbjörn
Posts: 2
Joined: Thu Mar 01, 2018 4:49 pm

dietpi-update/apt-get update Error

Post by bambusbjörn »

Hi,
at the moment I'm using v6.21.1 on my Odroid XU4.
I wanted to update my System to v6.22.3 by using dietpi-update but it failed. When using apt-get update I get the same error.
I already tried to change the APT Mirror (dietpi-config --> Network Options_ Misc --> APT Mirror) but the error is the same.
Does anybody know what to do?
Thanks in advance!
root@DietPi:~# apt-get update
Ign http://ftp.uk.debian.org jessie InRelease
Hit http://fuzon.co.uk all InRelease
Get:1 http://ftp.uk.debian.org jessie-updates InRelease [7,340 B]
Ign http://ftp.uk.debian.org jessie-backports InRelease
Hit http://fuzon.co.uk jessie InRelease
Hit http://ftp.uk.debian.org jessie Release.gpg
Ign http://ftp.uk.debian.org jessie-backports Release.gpg
Get:2 http://deb.debian.org jessie/updates InRelease [44.9 kB]
Hit http://ftp.uk.debian.org jessie Release
Ign http://ftp.uk.debian.org jessie-backports Release
Hit http://fuzon.co.uk all/xu3 armhf Packages
Hit http://fuzon.co.uk all/main armhf Packages
Hit http://fuzon.co.uk all/testing armhf Packages
Hit http://fuzon.co.uk jessie/main armhf Packages
Get:3 http://deb.debian.org jessie/updates/main armhf Packages [637 kB]
Hit http://fuzon.co.uk jessie/backports armhf Packages
Get:4 http://ftp.uk.debian.org jessie/main armhf Packages [6,675 kB]
Get:5 http://ftp.uk.debian.org jessie/contrib armhf Packages [37.8 kB]
Get:6 http://ftp.uk.debian.org jessie/non-free armhf Packages [62.5 kB]
Get:7 http://ftp.uk.debian.org jessie/contrib Translation-en [38.3 kB]
Get:8 http://ftp.uk.debian.org jessie/main Translation-en [4,581 kB]
Ign http://fuzon.co.uk all/main Translation-en_GB
Get:9 http://ftp.uk.debian.org jessie/non-free Translation-en [72.0 kB]
Ign http://fuzon.co.uk all/main Translation-en
Ign http://fuzon.co.uk all/testing Translation-en_GB
Get:10 http://deb.debian.org jessie/updates/non-free armhf Packages [4,243 B]
Ign http://fuzon.co.uk all/testing Translation-en
Ign http://fuzon.co.uk all/xu3 Translation-en_GB
Ign http://fuzon.co.uk all/xu3 Translation-en
Get:11 http://deb.debian.org jessie/updates/main Translation-en [335 kB]
Hit http://deb.debian.org jessie/updates/contrib armhf Packages
Hit http://deb.debian.org jessie/updates/contrib Translation-en
Get:12 http://deb.debian.org jessie/updates/non-free Translation-en [11.8 kB]
Ign http://fuzon.co.uk jessie/backports Translation-en_GB
Ign http://fuzon.co.uk jessie/backports Translation-en
Ign http://fuzon.co.uk jessie/main Translation-en_GB
Ign http://fuzon.co.uk jessie/main Translation-en
Err http://ftp.uk.debian.org jessie-backports/main armhf Packages
404 Not Found
Err http://ftp.uk.debian.org jessie-backports/contrib armhf Packages
404 Not Found
Err http://ftp.uk.debian.org jessie-backports/non-free armhf Packages
404 Not Found
Ign http://ftp.uk.debian.org jessie-backports/contrib Translation-en_GB
Ign http://ftp.uk.debian.org jessie-backports/contrib Translation-en
Ign http://ftp.uk.debian.org jessie-backports/main Translation-en_GB
Ign http://ftp.uk.debian.org jessie-backports/main Translation-en
Ign http://ftp.uk.debian.org jessie-backports/non-free Translation-en_GB
Ign http://ftp.uk.debian.org jessie-backports/non-free Translation-en
Fetched 52.3 kB in 20s (2,546 B/s)
W: Failed to fetch http://ftp.uk.debian.org/debian/dists/j ... /InRelease Unable to find expected entry 'main/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://ftp.uk.debian.org/debian/dists/j ... f/Packages 404 Not Found

W: Failed to fetch http://ftp.uk.debian.org/debian/dists/j ... f/Packages 404 Not Found

W: Failed to fetch http://ftp.uk.debian.org/debian/dists/j ... f/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
User avatar
MichaIng
Site Admin
Posts: 2421
Joined: Sat Nov 18, 2017 6:21 pm

Re: dietpi-update/apt-get update Error

Post by MichaIng »

Jep this is a known issue since Debian dropped backports and update branches for Jessie systems from their repository.

Please edit /etc/apt/sources.list and remove the jessie-backports and jessie-updates lines.

We will patch this as well with v6.23 update prior to APT is called.
bambusbjörn
Posts: 2
Joined: Thu Mar 01, 2018 4:49 pm

Re: dietpi-update/apt-get update Error

Post by bambusbjörn »

Thank you verry much! This solved the problem
jcw
Posts: 7
Joined: Tue Jun 05, 2018 8:52 pm

Re: dietpi-update/apt-get update Error

Post by jcw »

This also affects the Odroid C1 build, which is only available for Jessie AFAICT.

I wiped the unit and wanted to start afresh, but I can't get through the initial setup anymore.

It would be nice if you could update the C1 image as well - or is there a way to sidestep this when going through the initial setup? From what I can tell, you can't drop to the shell and adjust apt sources before apt update gets run.

-jcw
Kymru
Posts: 30
Joined: Wed Jan 25, 2017 6:40 pm

Re: dietpi-update/apt-get update Error

Post by Kymru »

jcw wrote: Fri Apr 26, 2019 10:44 am This also affects the Odroid C1 build, which is only available for Jessie AFAICT.

I wiped the unit and wanted to start afresh, but I can't get through the initial setup anymore.

It would be nice if you could update the C1 image as well - or is there a way to sidestep this when going through the initial setup? From what I can tell, you can't drop to the shell and adjust apt sources before apt update gets run.

-jcw
thats the exact problem i am having at the moment, fresh install for oDroid C1, fails to update
i am currently stuck with

Code: Select all

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
sh: 1: /usr/bin/xauth: not found
[  OK  ] Root access verified.
 ───────────────────────────────────────
 DietPi     | Update available
 ───────────────────────────────────────
 v#!/bin/bash.G_DIETPI_VERSION_CORE=6       | Odroid C1 (armv7l)
 ───────────────────────────────────────
 IP eth0    | 192.168.0.255
 ───────────────────────────────────────
Kymru
Posts: 30
Joined: Wed Jan 25, 2017 6:40 pm

Re: dietpi-update/apt-get update Error

Post by Kymru »

MichaIng wrote: Thu Apr 25, 2019 4:06 pm Jep this is a known issue since Debian dropped backports and update branches for Jessie systems from their repository.

Please edit /etc/apt/sources.list and remove the jessie-backports and jessie-updates lines.

We will patch this as well with v6.23 update prior to APT is called.
if i burn a C1 image to the eMMC, download and run the VMWare image of dietpi, mount the eMMC into the dietpi OS running in VMWare, could i edit the /etc/apt/sources.list that way?
User avatar
MichaIng
Site Admin
Posts: 2421
Joined: Sat Nov 18, 2017 6:21 pm

Re: dietpi-update/apt-get update Error

Post by MichaIng »

@Kymru
Jep that is possible. Meanwhile we have an Odroid C1 Stretch image. Sadly Stretch only works with the mainline kernel that lacks video features, thus no screen will work, only SSH and serial console access.

When running into the issue with the Jessie image on first boot, you can skip/break the setup to go into console, then remove the APT sources list lines as mentioned above. Then run: /DietPi/dietpi/login to re-run the first run update and setup steps.
Post Reply