DietPi no longer recognizing attached USB drives!

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
midnightwatcher
Posts: 54
Joined: Mon Dec 26, 2016 7:54 am

DietPi no longer recognizing attached USB drives!

Post by midnightwatcher »

This is odd. All of a sudden DietPi no longer recognizes my attached USB drives on my C2. Not sure if this is related to just having updated to v150 or not, but I tried disconnecting and reconnecting and nothing. I attached them to another Linux PC and it recognizes them both immediately, but something has happened with DietPi.

Update: It used to mount as a drive under mnt/root but no longer. DietPi-Drive Manager sees it. According to DPDM the mount target is /mnt/0dca34ad-xxxx-xxxx-xxxxxxxxxxx. Something has happened with DietPi that is affecting attached USB drives, at least in my case. I have a second USB drive as well and DPDM sees it but won't even mount it.

Update 2: I did another reboot, and now it is recognizing my first drive as it did before under mnt/root, but won't mount my second drive and it says that my second drive has No Filesystem, which it does.

Just submitted a bug report. Reference CODE: 8f057890-d20f-472a-a833-40f91647c53e-0
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: DietPi no longer recognizing attached USB drives!

Post by Fourdee »

Hi,

Thanks for the report.

It appears some old entries in your /etc/fstab still exist, these will throw out the updated UUID system in DietPi-Drive_manager. We did patch for this, however, appears unsuccessful on your system.

Please edit /etc/fstab and remove the following lines:

Code: Select all

/dev/sdb1       /mnt/usb_2      auto     defaults,noatime,nofail,x-systemd.automount  0 0
#/dev/sdc1       /mnt/usb_3      auto     defaults,noatime,nofail,x-systemd.automount  0 0
#/dev/sdd1       /mnt/usb_4      auto     defaults,noatime,nofail,x-systemd.automount  0 0
#/dev/sde1       /mnt/usb_5      auto     defaults,noatime,nofail,x-systemd.automount  0 0
Reload systemD:

Code: Select all

systemctl daemon-reload
Now relauch DietPi-Drive_manager and check status of drives:

Code: Select all

dietpi-drive_manager
In your bug report, the system is only detecting 1 USB drive, with 2 partitions. Is is possible the other drive is failing, lacks sufficient power?:

Code: Select all

/dev/sdb2: LABEL="KODI Media" UUID="0dca34ad-cbea-40cc-9378-19326ee894f0" TYPE="ext4" PARTLABEL="KODI 8GB" PARTUUID="d41d2c6f-6cdf-46d9-910c-22bf95d33cdb"
/dev/mmcblk0: PTUUID="d3630000" PTTYPE="dos"
/dev/sdb1: PARTLABEL="Microsoft reserved partition" PARTUUID="fe221213-413b-420f-9e72-b2a8a03c40de"
Yep, /dev/sda indicates IO failures/recovery:

Code: Select all

[  317.331517] EXT4-fs (sda1): recovery complete
[  317.331537] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[  534.190399] usb 1-1.2: USB disconnect, device number 16
[  534.190412] usb 1-1.2.1: USB disconnect, device number 17
[  534.191002] end_request: I/O error, dev sda, sector 0
[  534.194737] sd 3:0:0:0: [sda] Synchronizing SCSI cache
[  534.194862] sd 3:0:0:0: [sda]  
Also, this mount does not exist in /etc/fstab and should not exist, did you add this manually, how?

Code: Select all

/dev/sdb2       7.3T  3.9T  3.0T  57% /media/root/KODI Media
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
midnightwatcher
Posts: 54
Joined: Mon Dec 26, 2016 7:54 am

Re: DietPi no longer recognizing attached USB drives!

Post by midnightwatcher »

Fourdee, thank you, I didn't even think about fstab but this helped. I removed those entries and can now finally mount both drives again, this time I'm using the UUIDs.
Post Reply