DietPi AutoInstall Problem (armbiam-firmware 5.25 bug?)

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
dirks

DietPi AutoInstall Problem (armbiam-firmware 5.25 bug?)

Post by dirks »

I like to use the DietPi AutoInstall feature (configured with the /boot/dietpi.txt file) which works pretty well for me till today. I have setup a new NanoPiM1 system using this feature which works well till the SBC is rebootet the first time. After the reboot no network interface is working anymore. I'm not sure, but I believe the cause for this are automatic updates of these packages...

The following packages will be upgraded:
armbian-firmware armbian-tools-jessie libssl1.0.0 linux-image-sun8i linux-jessie-root-nanopim1 linux-u-boot-nanopim1-default ntfs-3g openssl sunxi-tools
9 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

The armbian-firmware and linux-image-sun8i packages are upgraded from version 5.24 to 5.25. During this upgrade process I have received error messages (see the attached NanoPiM1-Install.log).

I have tried to prevent this upgrade with the...

dietpi_check_for_updates=0

option (in the /boot/dietpi.txt file), but this does not work (the firmware updates will be still installed).

A second NanoPiM1 SBC which I have previously configured with the DietPi AutoInstall feature works very well with the armbian-firmware 5.24 till today.

Any ideas how to solve this problem?

Thx!

Regards,
Dirk
Attachments
NanoPiM1-Install.zip
includes the NanoPiM1-Install.log
(3.6 KiB) Downloaded 114 times
dirks

Re: DietPi AutoInstall Problem (armbiam-firmware 5.25 bug?)

Post by dirks »

Some more information:

1. after the first reboot the wlan0 interface is not working anymore
2. "dietpi-config / Network Options: Adapters" shows...

Wifi: Not found | Enabled | Disconnected

3. lsmod does not show that the module "8192cu" is loaded
-> my other NanoPiM1 SBC with the same USB WLAN-Stick has this module loaded!

4. the file /lib/modules/3.4.113-sun8i/kernel/net/wireless/8192cu.ko exits

5. the file /etc/modprobe.d/8192cu.conf exits

6. the directory /sys/module/8192cu does NOT exist!!!

7. trying to load the module with "modprobe 8192cu" shows...
FATAL: Module 8192cu not found

8. Remember: wlan0 works perfectly during the first start and DietPi AutoInstallation till the first reboot is done!

What has disabled the 8192cu support? (the armbian-firmware / linux-image-sun8i upgrade fron 5.24 to 5.25?)
How can I resolve this problem? (the reboot is automatically done during the installation process)
Any ideas?

Dirk
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: DietPi AutoInstall Problem (armbiam-firmware 5.25 bug?)

Post by Fourdee »

Hi Dirk,

These are the results I got 8 days ago:
https://github.com/Fourdee/DietPi/issue ... -275846502

Not sure what ARMbian is doing, or where they stand on USB WiFi support with 3.x for that matter:
https://github.com/igorpecovnik/lib/issues/611

Either way, I gave up trying to deal with them (Thomas), like hitting your head against a brick wall of nonsense. I've flagged this as no fix for now.

We are waiting for ARMbian to reach 4.10 kernel, then we will update the image as mainline kernel, has much better USB WiFi support and stability.
Why not 4.9? Onboard audio is only available from 4.10 onward:
https://linux-sunxi.org/Linux_mainlinin ... tus_Matrix
8. Remember: wlan0 works perfectly during the first start and DietPi AutoInstallation till the first reboot is done!
You could try holding those packages, preventing them from updating. But you'd need to do this before DietPi runs apt-get upgrade. So, no automated installs :(

Code: Select all

apt-mark hold armbian-firmware armbian-tools-jessie linux-image-sun8i linux-jessie-root-nanopim1 linux-u-boot-nanopim1-default
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
dirks

Re: DietPi AutoInstall Problem (armbiam-firmware 5.25 bug?)

Post by dirks »

Hi Fourdee,

thank you so much for spending your time!

I agree that you flagged this issue as no fix for now. Also thanks for your "apt-mark" instructions, that I've set now.

Just one question is left:
Did DietPi automatically runs the "apt-get upgrade" command if the initial DietPi installation is done (without user confirmation)?
Is it enough to set the "apt-mark" command once with the packages you have outlined?

Thx, have a nice day.

Dirk
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: DietPi AutoInstall Problem (armbiam-firmware 5.25 bug?)

Post by Fourdee »

dirks wrote:Did DietPi automatically runs the "apt-get upgrade" command if the initial DietPi installation is done (without user confirmation)?
Apt-get upgrade is run during the dietpi-software stage, after 1st run DietPi updates. So you could exit at this stage, then apply the package hold. Return to dietpi-software to complete the setup.

Although, we did trigger apt-get upgrade in patch v140, so if your image is, just checked, current is v142 for M1, should be fine.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply