Cpu usage while idle

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
desty_nova
Posts: 10
Joined: Fri Jul 03, 2020 3:48 pm

Cpu usage while idle

Post by desty_nova »

Hello everyone!

Recently I updated to a fresh install of the x64 diet version (coming from ruining 32 bits version for almost 1.5 year), but I noticed that cpu usage seems a bit more intense/active than it seemed on the 32 bit system.
Don't get me wrong, I know that CPU will never stop cycling and this is just a sample graph, but I remember very well that the CPU usage would stay in the 0.0 mark for a while before going up.
Can someone please enlighten me where I could start looking or if this behavior is expected?
Attachments
Screen Shot 2021-04-08 at 17.51.02.png
Screen Shot 2021-04-08 at 17.49.45.png
User avatar
Joulinar
Posts: 5652
Joined: Sat Nov 16, 2019 12:49 am

Re: Cpu usage while idle

Post by Joulinar »

Well CPU usage is around 0.1 - 0.2 %, which is nearly nothing. Most of the time is spend on Docker and RPI Monitor.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
desty_nova
Posts: 10
Joined: Fri Jul 03, 2020 3:48 pm

Re: Cpu usage while idle

Post by desty_nova »

@Joulinar, just for closure, this is totally related to the newest fix included in the newest dietpi-update updating the config.txt to dtparam=sd_poll_once. Now the very same setup of this original post has the cpu usage of around 0.03 while idle. Maybe I wasn't clear enough in my post and I definitely forgot to mention that I had upgraded to a SDless setup.
Anyway, thanks for the fix!
Attachments
Screen Shot 2021-08-31 at 14.34.47.png
Screen Shot 2021-08-31 at 14.25.39.png
Screen Shot 2021-08-31 at 14.25.08.png
User avatar
Joulinar
Posts: 5652
Joined: Sat Nov 16, 2019 12:49 am

Re: Cpu usage while idle

Post by Joulinar »

yes this is/was a default behaviour of Raspberry OS to constantly search for a SD card even if booted from USB. Issue was fixed based on following GitHub issue.

https://github.com/MichaIng/DietPi/issues/4602
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply