Lighttpd Fails to Start (Exit code 255)

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
808dot
Posts: 4
Joined: Fri Nov 08, 2019 10:32 am

Lighttpd Fails to Start (Exit code 255)

Post by 808dot »

Hello, I've just re-installed LLMP (Lighttpd, mariaDB, & php) on my DietPi, however when I try to run lighttpd it keeps failing. I've tried to troubleshoot but no luck yet. Could anyone please provide some help? Thanks!

When I run /etc/init.d/lighttpd start:

Code: Select all

[....] Starting lighttpd (via systemctl): lighttpd.serviceJob for lighttpd.service failed because the control process exited with error code.
See "systemctl status lighttpd.service" and "journalctl -xe" for details.
 failed!
When I run systemctl status lighttpd.service:

Code: Select all

● lighttpd.service - Lighttpd Daemon
   Loaded: loaded (/lib/systemd/system/lighttpd.service; disabled; vendor preset
: enabled)
   Active: failed (Result: exit-code) since Wed 2019-11-13 08:53:45 G
MT; 2s ago
  Process: 18881 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.c
onf (code=exited, status=255)

Nov 13 08:53:45 DietPi systemd[1]: lighttpd.service: Unit entered failed
 state.
Nov 13 08:53:45 DietPi systemd[1]: lighttpd.service: Failed with result 
'exit-code'.
Nov 13 08:53:45 DietPi systemd[1]: lighttpd.service: Service hold-off time over,
 scheduling restart.
Nov 13 08:53:45 DietPi systemd[1]: Stopped Lighttpd Daemon.
Nov 13 08:53:45 DietPi systemd[1]: lighttpd.service: Start request repea
ted too quickly.
Nov 13 08:53:45 DietPi systemd[1]: Failed to start Lighttpd Daemon.
Nov 13 08:53:45 DietPi systemd[1]: lighttpd.service: Unit entered failed
 state.
Nov 13 08:53:45 DietPi systemd[1]: lighttpd.service: Failed with result 
'exit-code'.
When I run journalctl -xe, these seem to be the only errors:

Code: Select all

Nov 13 08:51:18 DietPi agetty[18704]: /dev/ttyS0: not a tty
Nov 13 08:51:18 DietPi agetty[18705]: /dev/ttyS1: not a tty
Nov 13 08:51:18 DietPi agetty[18706]: /dev/ttyS2: not a tty

My /etc/lighttpd/lighttpd.conf file:

Code: Select all

server.pid-file             = "/var/run/lighttpd.pid"
server.username             = "www-data"
server.groupname            = "www-data"
server.port                 = 80


index-file.names            = ( "index.php", "index.html", "index.lighttpd.html$
url.access-deny             = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ( "application/javascript", "text/css", "text/htm$

# default listening port for IPv6 falls back to the IPv4 port
include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.assign.pl"
include_shell "/usr/share/lighttpd/include-conf-enabled.pl"

Post Reply