XU4 Cloudshell HDD Unmounting on its own Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Kiomon

XU4 Cloudshell HDD Unmounting on its own

Post by Kiomon »

I have a XU4 Coudshell with DietPi running off the eMMC chip, and a 4TB 2.5 inch hard drive inside. Dietpi has been set the hard drive to permanent. We are basically just running Plex, PiHole, and SMB Server on the Cloudshell.

Everything is working except that the harddrive seems to unmount randomly. Typically it happens during a long file transfer (4GB+), the drive will just unmount itself, and the file transfer will fail. I then have to remount the drive.

Upon boot up the drive is typically "sda" and then it will unmount and be listed as "sdb" and continually increment as it unmounts. If i don't do any file server efforts, then its typically stable for days on end.

If i do local file transfers (plug a USB stick into the unit), they are stable, though after they all complete, the drive will sometimes go offline. But that is rare. Its typically after/during network transfers.

Any ideas?
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: XU4 Cloudshell HDD Unmounting on its own

Post by johnvick »

I have a similar setup and remember reading that the USB 3 sockets had some sort of coating on the inside that could result in poor electrical contact - the advice was to clean them with a cotton bud and alcohol. Worth a try maybe? I have had the occasional random dismount but not to the extend you describe.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: XU4 Cloudshell HDD Unmounting on its own

Post by johnvick »

Another thought occurred - are you using the stock power supply? If so it may not be providing enough to power that big drive.
Kiomon

Re: XU4 Cloudshell HDD Unmounting on its own

Post by Kiomon »

We are using a seperate dc power supply. Its rated at 10A. This is the one.

https://smile.amazon.com/gp/product/B00 ... =UTF8&th=1

What's odd is that when I do the built is disk test and such that doesn't seem to cause it to unmount and that's a lot of disk i/o vs the 10 megabytes a second in SMB. I haven't tried cleaning the USB plug, but I will try that tomorrow.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 Cloudshell HDD Unmounting on its own

Post by Fourdee »

Kiomon wrote:We are using a seperate dc power supply. Its rated at 10A. This is the one.

https://smile.amazon.com/gp/product/B00 ... =UTF8&th=1

What's odd is that when I do the built is disk test and such that doesn't seem to cause it to unmount and that's a lot of disk i/o vs the 10 megabytes a second in SMB. I haven't tried cleaning the USB plug, but I will try that tomorrow.
I've seen a lot of PSU's in my time, but nothing like that lol. Intresting setup :)

Might be worth checking the voltage output is a stable 5v when XU4 is on. You can stress the system with dietpi-config > Tools > Stress
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply