Tinker Board rev 1.2 not booting / Image

I tried to install dietpi for the first time on my tinkerboard rev 1.2 - tried the following image, but the machine is not booting:


I connect the tinkerboard by lan, but only the red led is on. I used a sd card with 128GB. What i´m doing wrong? Do have to add settings before booting the first time?

maybe something changed on that revision. Best would be to connect UART adapter and check what happen during boot.

I don’t have something like this. Any oder idea?

Without any log it is nearly impossible to investigate further

I have the same problem on my TinkerBoard S, but only when I try to install DietPi on the eMMC, on SD Card works seamlessly, if I purchase this uart adapter, can someone guide me?

Theoretically we could assist. Important, get an adapter that is supported which modern Windows / Mac systems.

@Joulinar the one you own worked OOTB on Windows 11, right?

Mine works OOTB on Windows 10 and 11, but the plastic cover is a bit annoying to fiddle with: CP2102 USB zu TTL Konverter HW-598 für 3,3V und 5V mit Jumper Kabel

I am still looking for a reliable one with only the 3 needed cables, so that it can be ruled out to accidentally attack the additional power cable to the wrong pin.

Yes, mine works without any problems with Windows 11