First run FAILED Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
reklam
Posts: 8
Joined: Wed Nov 10, 2021 12:02 pm

Re: First run FAILED

Post by reklam »

I start from the beginning, delete sd card, install, and start from the beginning.
Now I select to install xfce and choose desktop to xfce.
Now failed from other place....
20211113_215414.jpg
So this OS is not only hard to install, but impossible.

Thank you so much for your help to all of you.
User avatar
MichaIng
Site Admin
Posts: 3514
Joined: Sat Nov 18, 2017 6:21 pm

Re: First run FAILED

Post by MichaIng »

Your SD card seems broken. This means that the intended install state was not written, or probably the boot partition got suddenly unmounted. Additionally to the commands provided above, please check the following to check for kernel errors:

Code: Select all

dmesg -l emerg,alert,crit,err
reklam
Posts: 8
Joined: Wed Nov 10, 2021 12:02 pm

Re: First run FAILED

Post by reklam »

Hi,
No problem with SD card. Other system runing well on it.
I am pretty sure I do something wrong.
I am a beginner in the Linux world, and exremly hard to install this system to me.
Most of the question I just push something, because I do not understand.
If I click "next next next" without change anything /xfce, chrome/ the system stuck with firefox, there is something wrong with firefox installer.
If I change only firefox to chrome, the system installing, but not on desktop mode, and I do not know how to get in.
So I think it is my fault, but do not know what to do.
If I cahnge something, all time coming differnt and different problem.
User avatar
MichaIng
Site Admin
Posts: 3514
Joined: Sat Nov 18, 2017 6:21 pm

Re: First run FAILED

Post by MichaIng »

Please run the command I provided and paste the output here. At best run things via SSH connection so that you can select for copy&paste the console text, instead of taking photos of the screen.

The screen photo you showed can only happen in two cases:
1. The content of the boot partition is not as expected, which is (in combination with the previous "Failed to load DietPi-Globals" error you faced) why I thought about an SD card issue, filesystem corruption or similar. This could be verified by the given command.
2. DietPi-Update or DietPi-Software encountered an error. In this case you should have seen an error prompt before the one you showed and we'd need the error messages given there.

Clicking "next next next" should be fine, however you'll have a minimal install without desktop or browser then. Note that the "Preference" selections, as stated in those menus, only define a preference (for a desktop or browser or webserver) IF (and only if!) another explicitly selected software requires such. E.g. if you select Nextcloud, the webserver preference will be respected to install the webserver of your choice, since Nextcloud requires a webserver. Same for VNC servers and desktop applications and the desktop preference. The browser preference defines the browser that will be installed IF you select a desktop explicitly (not via preference menu only). But this should be all described well in the menus. You can hit "next next next", but at least read the text that is given if you expect any specific outcome ;).

This means, I guess you didn't chose a desktop or browser via "Browse Software" or "Seach Software" menus, but only via preference menus, which results in nothing being installed, as stated above. But it doesn't explain the errors you faced.
reklam
Posts: 8
Joined: Wed Nov 10, 2021 12:02 pm

Re: First run FAILED

Post by reklam »

Hello,
I found it what was the problem.
I used the RPi Imager to make the SD card.

Now last time, I make with balenaEtcher and was no fail message anymore, it worked for the first time.

So cannot use RPi Imager, because it couse all the problem what I got.
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: First run FAILED

Post by Joulinar »

balenaEtcher is the tool we recommend to use to flash the images. https://dietpi.com/docs/install/#2-flas ... etpi-image
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3514
Joined: Sat Nov 18, 2017 6:21 pm

Re: First run FAILED

Post by MichaIng »

Hmm, RPi imager works fine for me, just tested it a couple of times. It has some options to pre-configure parts of the boot partition, enable SSH etc, but those are only valid for the official Raspberry Pi OS image. Did you probably change something with these and it was applied even when using a custom local image file? If so, we should add a fix to have these additional options only applied when the regular RPi OS image is downloaded, or based on a specific marker when using a local image.
reklam
Posts: 8
Joined: Wed Nov 10, 2021 12:02 pm

Re: First run FAILED

Post by reklam »

Hi,

No I did not changed anything /I do not know how can I/
I started the RPi Imager on Windows 10 pro, Choose OS, scroll down, Use Custom.
I choose the DietPi_RPi-ARMv8-Bullseye.img , after Choose Storage, only one there what I can choose.
Write.
RPi Imager wersion 1.6.2
RPi4B 8GB /newest cpu inside, end with ..6C0T/ I bought a month ago only.
User avatar
MichaIng
Site Admin
Posts: 3514
Joined: Sat Nov 18, 2017 6:21 pm

Re: First run FAILED

Post by MichaIng »

Strange, I'll retest with RPi-Imager when I find time. Usually I use Rufus to write images from Windows, much smaller and faster and still more advanced than Etcher ;).
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: First run FAILED

Post by Joulinar »

Jup switch to Rufus as well, exactly for same reason.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply