How to install KODI 18.7 on Bullseye? Topic is solved

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
ChatNoir666
Posts: 3
Joined: Wed Nov 10, 2021 10:38 am

How to install KODI 18.7 on Bullseye?

Post by ChatNoir666 »

Hello,

I'm trying the new Bullseye Arm7 Version on an USB-Stick on my RP3+b and so far I've seen the Version of KODI is 19.1:
Candidate: 2:19.1+dfsg2-2

All my other Mutimedia Pi's and Computers are on 18.7 and I really want to keep it (external MySQL Database, own made Addons aso...)

So how can I install 18.7 on Bullseye?

Best regards,
Chris
User avatar
MichaIng
Site Admin
Posts: 3514
Joined: Sat Nov 18, 2017 6:21 pm

Re: How to install KODI 18.7 on Bullseye?

Post by MichaIng »

No chance without compiling it manually. The Kodi 18.7 package came from the Raspberry Pi repository, but it cannot be installed on Bullseye due to a large amount of mismatching dependencies/system libraries.
ChatNoir666
Posts: 3
Joined: Wed Nov 10, 2021 10:38 am

Re: How to install KODI 18.7 on Bullseye?

Post by ChatNoir666 »

Ouch...
I don't have any experience with compiling...

Any other way like Docker or so?
Or do I need to use your Buster Version?

Oh and thank you for your response! :)


[EDIT]: Apropos Buster: Your Download-Section only shows Bullseye, so where can I find it?

Oh and if I go back to Buster, I guess I can't use the Backup made with Bullseye for restoring my settings, or?
User avatar
MichaIng
Site Admin
Posts: 3514
Joined: Sat Nov 18, 2017 6:21 pm

Re: How to install KODI 18.7 on Bullseye?

Post by MichaIng »

Yeah, compiling Kodi isn't much fun, I have to say. It takes up to two days here on an RPi :lol:. Instead of running it with the Docker overhead or running 2+ years outdated distribution version, I suggest to update your apps to work with recent Kodi versions. I guess it will be possible to migrate a Kodi 18 database to Kodi 19, probably it does it automatically? This will cause you mid/long term much less pain and effort compared to the alternatives.

You have no backup of the Buster system? If so, you can restore it which will fully restore the Buster system. Similarly, if you have a Bullseye backup and restore it on a Buster system, it would basically be upgraded to Bullseye ;). We do not promote old downloads, as this causes more issues than it solves.

If you really want to revert to a fresh Buster system, PM me.
ChatNoir666
Posts: 3
Joined: Wed Nov 10, 2021 10:38 am

Re: How to install KODI 18.7 on Bullseye?

Post by ChatNoir666 »

Well...
I'm not the only one who don't like KODI 19 with all the problems it brings with it... ;)
This will cause you mid/long term much less pain..
I've read much about KODI 19 in forums, discords, reddits and there was much "pain" :D
And many "I'm happy now that I've downgraded to 18.7" (or 18.9). ;)

Anyway, I want to get more experience with Docker so I'll try this first before I revert.
But good to know that I can send you a PM for getting Buster! :)

I have a backup somewhere from DietPi Buster but I made some... well... clumsy things and I want to prevent this on a new DietPi. ;)
Also it was the Arm6 one and I wanted to test Arm7 now...

Anyway great work with Bullseye I've seen so far!!! *thumbs_up* :)
User avatar
MichaIng
Site Admin
Posts: 3514
Joined: Sat Nov 18, 2017 6:21 pm

Re: How to install KODI 18.7 on Bullseye?

Post by MichaIng »

IMHO running an old unmaintained software version because of being unhappy with the new one isn't a sustainable solution. Probably it makes more sense to report the issues with it, trying to get bugs fixed and enhancements added. Best to reach developers directly is doing so in GitHub (respectively the code repository): https://github.com/xbmc/xbmc/issues
Thanks to open source and public code repositories, pull requests with the intended changes can be offered directly, if one has some knowledge about that code :).
DarrenHill
Posts: 59
Joined: Wed May 08, 2019 3:00 pm

Re: How to install KODI 18.7 on Bullseye?

Post by DarrenHill »

When you go from 18.x Leia to 19.x Matrix, the database will update automatically and a new one will be created on your MySQL or MariaDB server (presuming that's where it's centrally stored). All Kodi devices linked to it will use the appropriate version of the database for their installed Kodi version, but there will be no "cross-communication" between them.

So for example new shows or movies added on an 18.x machine won't appear on a 19.x one, and the watched statuses between the two version families will no longer synchronise (shows watched on an 18.x machine will appear as watched on other 18.x machines, but not on 19.x ones).

The main reason for the "pain" is the enforced update of the Python version used between Leia and Matrix. Leia and its addons are based around Python 2, which of course is now EOL and will no longer receive any security (or other) updates. So we were forced to update to Python 3 in Matrix (and beyond - Nexus and all future versions will be based on Python 3).

As the two languages are not compatible with one another, there was a hard divide drawn, and Python 2 addons for Leia will not work on Matrix due to this. It is of course possible for authors to update their addons to the new language, and indeed many have done so and a majority of addons are still fully available.

But it has had the other effects of allowing a lot of the old/dead/unsupported addons to be removed from our ecosystem, which is generally positive but may impact on some people who were still using them even in that state. And of course a lot of the older piracy addons have also fallen by the wayside. For us that is a good thing, but for some elements of our user base it would be less desirable.
User avatar
MichaIng
Site Admin
Posts: 3514
Joined: Sat Nov 18, 2017 6:21 pm

Re: How to install KODI 18.7 on Bullseye?

Post by MichaIng »

Okay, but is Kodi really to blame for moving forward and finally dropping an EOL Python version? I see that Kodi 17 and 18 seem to not support Python 3 yet but Python 2 only (?) and Python 19 does only support Python 3, so a transition version with support for both would have been nice. However, major version increments are meant to not assure backwards compatibility, so whenever a major version update is available, you simply know that you cannot rely on any previous things to work. So only upgrade if you do not rely on it. For Buster => Bullseye, as long as you do not want to compile an old Kodi yourself, do not upgrade as long as you rely on an addon for Kodi 18 and earlier.

That Python 2 is EOL since beginning of 2020 is and was pretty clear to everyone, so it was pretty clear too that Kodi 19 won't support it anymore and I'm pretty sure they provided this information early on all developer channels they have. So addon developers had plenty of time to make their addons Python 3 compatible. Of course some are spare time projects, and unpaid open source addon developers are not to blame for not maintaining their addon to stay compatible with modern language/framework/software versions, but Kodi is neither to blame for this. It is simply to be accepted by users and do their decisions accordingly ;).
DarrenHill
Posts: 59
Joined: Wed May 08, 2019 3:00 pm

Re: How to install KODI 18.7 on Bullseye?

Post by DarrenHill »

There were test builds of Leia (v18.x) that used Python 3, whilst the release version was the final one using Python 2. Plus there were of course all of the alpha/beta/RC versions of Matrix (v19.x) which were available whilst Leia was the stable release one.

These were prepared to allow addon developers to update their code in preparedness for the switch, plus it was announced and publicised well in advance. Many addon developers took advantage of it, some did not.

Should also clarify for transparency that I'm a member of Team Kodi, although not a hands-on core developer. We did (and are occasionally still do) get a lot of complaints from users who assume that we provide all of the 3rd party piracy addons (which we don't), and when their pirated Netflix/HBO/Prime/movie sources suddenly stop working, it is of course us they try to lay the blame on, when quite frankly we're usually glad when all the piracy stuff that's tarnishing our good name stops working and gets binned...
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: How to install KODI 18.7 on Bullseye?

Post by Joulinar »

@DarrenHill
it's off topic but probably you could assist us on some kodi challenges. In last weeks we where struggling to get kodi 19 running on RPi4. Pls correct me if I'm wrong @MichaIng and issue has been solved in meantime. :)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply