"Too many errors" during upgrade to buster - no access to Rasp Pi anymore

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
Bademeister
Posts: 5
Joined: Tue Oct 26, 2021 3:30 pm

"Too many errors" during upgrade to buster - no access to Rasp Pi anymore

Post by Bademeister »

Hello,

I recently got the message to upgrade to buster. I followed the instructions of:
https://dietpi.com/docs/usage/#how-to-upgrade-to-buster

During apt upgrade or apt full-upgrade ( I am not sure anymore) this (see code below) happened. After I was not able to access the raspberry PI via ssh. A power off/on did not solve the problem.
I created a backup before the upgrade but I do not know how to restore it now. Is there anything what I can do before I format the sd card and do a fresh dietpi installation?
Thanks!

Code: Select all

Preparing to unpack .../096-libpipeline1_1.5.1-2_armhf.deb ...
Unpacking libpipeline1:armhf (1.5.1-2) over (1.4.1-2) ...
dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/096-libpipeline1_1.5.1-2_armhf.deb (--unpack):
 cannot copy extracted data for './usr/lib/arm-linux-gnueabihf/libpipeline.so.1.5.1' to '/usr/lib/arm-linux-gnueabihf/libpipeline.so.1.5.1.dpkg-new': unexpected end of file or stream
Preparing to unpack .../097-binfmt-support_2.2.0-2_armhf.deb ...
Unpacking binfmt-support (2.2.0-2) over (2.1.6-2) ...
Preparing to unpack .../098-openssl_1.1.1d-0+deb10u7_armhf.deb ...
Unpacking openssl (1.1.1d-0+deb10u7) over (1.1.0l-1~deb9u4) ...
Preparing to unpack .../099-ca-certificates_20200601~deb10u2_all.deb ...
Unpacking ca-certificates (20200601~deb10u2) over (20200601~deb9u2) ...
Selecting previously unselected package libisl19:armhf.
Preparing to unpack .../100-libisl19_0.20-2_armhf.deb ...
Unpacking libisl19:armhf (0.20-2) ...
Selecting previously unselected package cpp-8.
Preparing to unpack .../101-cpp-8_8.3.0-6+rpi1_armhf.deb ...
Unpacking cpp-8 (8.3.0-6+rpi1) ...
Preparing to unpack .../102-cpp_4%3a8.3.0-1+rpi2_armhf.deb ...
Unpacking cpp (4:8.3.0-1+rpi2) over (4:6.3.0-4) ...
Preparing to unpack .../103-libbsd0_0.9.1-2+deb10u1_armhf.deb ...
Unpacking libbsd0:armhf (0.9.1-2+deb10u1) over (0.8.3-1+deb9u1) ...
Preparing to unpack .../104-cvs_2%3a1.12.13+real-27_armhf.deb ...
Unpacking cvs (2:1.12.13+real-27) over (2:1.12.13+real-22+deb9u1) ...
dpkg-deb (subprocess): decompressing archive member: internal gzip read error: '<fd:4>: invalid stored block lengths'
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/104-cvs_2%3a1.12.13+real-27_armhf.deb (--unpack):
 cannot copy extracted data for './usr/share/doc/cvs/cvs.txt.gz' to '/usr/share/doc/cvs/cvs.txt.gz.dpkg-new': unexpected end of file or stream
Preparing to unpack .../105-device-tree-compiler_1.4.7-4_armhf.deb ...
Unpacking device-tree-compiler (1.4.7-4) over (1.4.4-1) ...
Preparing to unpack .../106-libdevmapper1.02.1_2%3a1.02.155-3_armhf.deb ...
Unpacking libdevmapper1.02.1:armhf (2:1.02.155-3) over (2:1.02.137-2) ...
Preparing to unpack .../107-dmsetup_2%3a1.02.155-3_armhf.deb ...
Unpacking dmsetup (2:1.02.155-3) over (2:1.02.137-2) ...
Preparing to unpack .../108-dosfstools_4.1-2_armhf.deb ...
Unpacking dosfstools (4.1-2) over (4.1-1) ...
Selecting previously unselected package libtommath1:armhf.
Preparing to unpack .../109-libtommath1_1.1.0-3_armhf.deb ...
Unpacking libtommath1:armhf (1.1.0-3) ...
Selecting previously unselected package libtomcrypt1:armhf.
Preparing to unpack .../110-libtomcrypt1_1.18.2-1_armhf.deb ...
Unpacking libtomcrypt1:armhf (1.18.2-1) ...
Preparing to unpack .../111-dropbear-bin_2018.76-5_armhf.deb ...
Unpacking dropbear-bin (2018.76-5) over (2016.74-5+deb9u1) ...
Preparing to unpack .../112-dropbear-run_2018.76-5_all.deb ...
Unpacking dropbear-run (2018.76-5) over (2016.74-5+deb9u1) ...
Preparing to unpack .../113-ethtool_1%3a4.19-1_armhf.deb ...
Unpacking ethtool (1:4.19-1) over (1:4.8-1) ...
Preparing to unpack .../114-firmware-atheros_1%3a20190114-2+rpt3_all.deb ...
Unpacking firmware-atheros (1:20190114-2+rpt3) over (1:20161130-3+rpt4) ...
dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/114-firmware-atheros_1%3a20190114-2+rpt3_all.deb (--unpack):
 subprocess dpkg-deb --fsys-tarfile returned error exit status 2
Preparing to unpack .../115-firmware-brcm80211_1%3a20190114-2+rpt3_all.deb ...
Unpacking firmware-brcm80211 (1:20190114-2+rpt3) over (1:20161130-3+rpt4) ...
Preparing to unpack .../116-firmware-iwlwifi_1%3a20190114-2+rpt3_all.deb ...
Unpacking firmware-iwlwifi (1:20190114-2+rpt3) over (1:20161130-3+rpt4) ...
dpkg: error while cleaning up:
 subprocess rm command for cleanup was killed by signal (Segmentation fault)
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/117-firmware-misc-nonfree_1%3a20190114-2+rpt3_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/118-firmware-realtek_1%3a20190114-2+rpt3_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/119-galera-3_25.3.25-2_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/120-libcc1-0_8.3.0-6+rpi1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/121-libgomp1_8.3.0-6+rpi1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/122-libasan5_8.3.0-6+rpi1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/123-libubsan1_8.3.0-6+rpi1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/124-libgcc-8-dev_8.3.0-6+rpi1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/125-gcc-8_8.3.0-6+rpi1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/126-gcc_4%3a8.3.0-1+rpi2_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/127-libdbus-glib-1-2_0.110-4_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/128-gconf-service_3.2.6-5_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/129-libgconf-2-4_3.2.6-5_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/130-gconf2-common_3.2.6-5_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/131-git-doc_1%3a2.20.1-2+deb10u3_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/132-git-el_1%3a2.20.1-2+deb10u3_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/133-gsettings-desktop-schemas_3.28.1-1_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/134-hdparm_9.58+ds-1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/135-htop_2.2.0-1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/136-imagemagick-6-common_8%3a6.9.10.23+dfsg-2.1+deb10u1_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/137-libnl-genl-3-200_3.4.0-1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/138-libnl-3-200_3.4.0-1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/139-iw_5.0.1-1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/140-libaio1_0.3.112-3_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/141-libapparmor1_2.13.2-10_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/142-libapt-inst2.0_1.8.2.3_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/143-libasound2_1.1.8-1+rpt1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/144-libasound2-data_1.1.8-1+rpt1_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/145-libatk1.0-0_2.30.0-2_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/146-libatk1.0-data_2.30.0-2_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/147-libatspi2.0-0_2.30.0-7_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/148-libatk-bridge2.0-0_2.30.0-5_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/149-libavahi-common-data_0.7-4+deb10u1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/150-libavahi-common3_0.7-4+deb10u1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/151-libavahi-client3_0.7-4+deb10u1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/152-libb-hooks-endofscope-perl_0.24-1_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/153-libcairo-gobject2_1.16.0-4+rpt1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/154-libcgi-pm-perl_4.40-1_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/155-liblcms2-2_2.9-3_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/156-libcolord2_1.4.3-4_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/157-libconfig-inifiles-perl_3.000001-1_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/158-libdatetime-format-strptime-perl_1.7600-1_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/159-libdatetime-format-builder-perl_0.8100-2_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/160-libdrm-common_2.4.100-4+rpi1~bpo10+1_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/161-libdrm2_2.4.100-4+rpi1~bpo10+1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/162-libedit2_3.1-20181209-1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/163-libepoxy0_1.5.3-0.1_armhf.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: error processing archive /tmp/apt-dpkg-install-V9KTtH/164-liberror-perl_0.17027-2_all.deb (--unpack):
 subprocess dpkg-split returned error exit status 11
dpkg: too many errors, stopping
dpkg: error: error executing hook 'if { test "$DPKG_HOOK_ACTION" = add-architecture || test "$DPKG_HOOK_ACTION" = remove-architecture; } && test -x /usr/share/pkg-config-dpkghook; then /usr/share/pkg-config-dpkghook update; fi', exit code 11
E: Sub-process /usr/bin/dpkg returned an error code (2)
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: "Too many errors" during upgrade to buster - no access to Rasp Pi anymore

Post by Joulinar »

Hi,

Where did you stored the backup? On the SD card themselves or on an external USB pen stick?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Bademeister
Posts: 5
Joined: Tue Oct 26, 2021 3:30 pm

Re: "Too many errors" during upgrade to buster - no access to Rasp Pi anymore

Post by Bademeister »

It is on the sd card. I checked the sd card on another pc, the backup is in rootfs/mnt/dietpi-backup.
So one idea would be to make a backup of this backup, do a clean dietpi installation and afterwards restore the backup. Correct?
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: "Too many errors" during upgrade to buster - no access to Rasp Pi anymore

Post by Joulinar »

Nearly correct. There is an option to restore a backup during first initial setup already. Just need to activate this on config files before first boot. Best to use a 2nd SD card to install a new system on it and restore from original SD card.

Another option is to connect a screen to your device to see if there are errors.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Bademeister
Posts: 5
Joined: Tue Oct 26, 2021 3:30 pm

Re: "Too many errors" during upgrade to buster - no access to Rasp Pi anymore

Post by Bademeister »

Thanks for the help!
I connected the Raspberry to an external monitor. The last command is:

Code: Select all

---[ end Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b
I tok a photo of the monitor, so if it is of interest I can post it.

The next step was a clean dietpi installation and a restore of the backup. In the end it said I have to do a reboot, but which did not work because something was missing. After power off and on the Raspberry is not accessible anymore (via LAN). So same problem like before.

I think I better do a clean installation and setup dietpi from beginning. I mostly used it for syncthing and baikal. Maybe it works to copy just the userdata of the old installation to the new installation. I will try it.
User avatar
Joulinar
Posts: 6441
Joined: Sat Nov 16, 2019 12:49 am

Re: "Too many errors" during upgrade to buster - no access to Rasp Pi anymore

Post by Joulinar »

hmm there could be some issues with your SD card. At least that would explain the issues you had during the update to extract the data and on your kernel panic.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply