Live Patches Disabled AdGuard?

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
Rhizome
Posts: 54
Joined: Sun Jun 27, 2021 5:22 pm

Live Patches Disabled AdGuard?

Post by Rhizome »

Adguard Home stopped blocking ads after installation of several live patches about a week ago. A few days ago I noticed that DNS queries were half of the normal. Today after checking the Dashboard, there are zero DNS enquiries, Clients, etc (see screenshot.)
https://1drv.ms/u/s!AnJqbLp2z67ygetl4nI ... g?e=BEYZUP
What's the best way to get AdGuard working again? I don't recall the patch names, just the numbers (1-4) so I'm guessing I need to walk through the entire configuration?
User avatar
Joulinar
Posts: 6001
Joined: Sat Nov 16, 2019 12:49 am

Re: Live Patches Disabled AdGuard?

Post by Joulinar »

Our live patches don't have any influence in a running application. We correct simple code blocks on our own DietPi scripts.

If AGH is not working, it's an issue on AGH themselves. As AGH is a single executable, you could simply reinstall it. If there are no queries, your clients most probably don't use AGH anymore. Have a look to your clients what DNS Server they are using.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Rhizome
Posts: 54
Joined: Sun Jun 27, 2021 5:22 pm

Re: Live Patches Disabled AdGuard?

Post by Rhizome »

Somehow the devices are using the 9.9.9.9 DNS settings of the router.
If I reinstall, do I need to backup all my AGH settings for reuse?
User avatar
Joulinar
Posts: 6001
Joined: Sat Nov 16, 2019 12:49 am

Re: Live Patches Disabled AdGuard?

Post by Joulinar »

Why do you like to reinstall? You need to check where your systems get these data from? Do you have a 2nd DHCP server active? Like the router? Or are you distributing a primary and a secondary DNS via your DHCP server settings?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply