Weird error on startup with caja

Required Information

  • DietPi version | 8.9.2
  • Distro version | bullseye
  • Kernel version | Linux DietPi 5.10.144-meson64 #22.08.2 SMP PREEMPT Wed Sep 21 19:02:36 UTC 2022 aarch64 GNU/Linux
  • SBC model | Odroid HC4)

Additional Information (if applicable)

  • Software title | MATE¿?
  • Can this issue be replicated on a fresh installation of DietPi?
    For me, it has happened always, also on bullseye 4.9 the error was still present.

Steps to reproduce

  1. Login on xrdp
  2. Mate desktop starts
  3. Try to open a window explorer from the menu entries
  4. Nothing happens

Expected behaviour

  • Explorer windows opens

Actual behaviour

  • Nothing happened when opening an entry menu.

This error has happening me always, when system recently starts I can’t open any caja window clicking on an entry menu.
On console I get this error when running caja:
Could not register the application: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface “org.gtk.Actions” on object at path /org/mate/Caja

I found some info on Google about the error…
https://www.pclinuxos.com/forum/index.php?topic=154748.0
https://bugzilla.redhat.com/show_bug.cgi?id=1469548
https://github.com/NixOS/nixpkgs/issues/83023
https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1666756.html

I tried to replicate but it’s working fine on my test system NanoPi R5S.

I installed XRDP and Mate without any browser. RDP login is working fine, and I could open items that are located unter Places. Even typing caja into terminal window is working fine.

Which user you are using to login? At least no issue on user dietpi as well :thinking:

It happens with both users root and dietpi, but it seems that is at the beginning, because after a time the error on terminal dissapears, and the elements on places seems to be working as normal, that’s why I said it’s weird…

maybe it is taking a while for the desktop to finish loading?

Just tried on my RPi 4B. No issues there as well. Explorer is available right after login using XRDP.

OK, just posting in order to see in someone else having the issue.

Thanks @Joulinar for your support!

sorry that I’m not able to assist further on this :frowning:

1 Like