Kodi - Unable to create GUI

Having issues with your DietPi installation or found a bug? Post it here.
Milemar
Posts: 10
Joined: Mon May 17, 2021 11:15 pm

Re: Kodi - Unable to create GUI

Post by Milemar »

Just a quick question to clarify. What Kodi version should be installed on 64-bit dietpi when choosing it from dietpi-software?

I am asking this as the Kodi website states that the newest version for Rpi OS is Leia 18.7) but the one that I have installed is Kodi from Debian 17.6.

When I check for updates, I am getting all up to date:

Code: Select all

root@Kodi:~# apt-get update
Hit:1 https://deb.debian.org/debian buster InRelease
Hit:2 https://deb.debian.org/debian buster-updates InRelease
Hit:3 https://deb.debian.org/debian-security buster/updates InRelease
Hit:4 https://archive.raspberrypi.org/debian buster InRelease
Hit:5 https://deb.debian.org/debian buster-backports InRelease
Reading package lists... Done
root@Kodi:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@Kodi:~#
Why is that?
Am I missing some repository?
User avatar
Joulinar
Posts: 5149
Joined: Sat Nov 16, 2019 12:49 am

Re: Kodi - Unable to create GUI

Post by Joulinar »

Kodi is installed from official Debian repository. Hence it is 17.6 on arm64

https://packages.debian.org/buster/kodi
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3106
Joined: Sat Nov 18, 2017 6:21 pm

Re: Kodi - Unable to create GUI

Post by MichaIng »

As the version from Raspberry Pi OS is still for 32-bit only :(.
Post Reply