Nextcloud 21 released and won't install on dietpi Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
HelloGoodbye
Posts: 6
Joined: Tue Feb 11, 2020 5:08 am

Nextcloud 21 released and won't install on dietpi

Post by HelloGoodbye »

I was playing around with nextcloud talk yesterday and something went funny with an upgrade so i decided to do a fresh install of nextcloud/nextcloud talk as it was only installed earlier that day...well it turns out it version 21 was released some point after my first install and now i can't get everything working again. Everything seems ok with Nextcloud but dietpi won't let me install nextcloud talk. I was getting a spreed issue. I tried looking into it on nextcloud but it was an old issue for a few years ago and nothing would help me fix it.
HelloGoodbye
Posts: 6
Joined: Tue Feb 11, 2020 5:08 am

Re: Nextcloud 21 released and won't install on dietpi

Post by HelloGoodbye »

error
error
- Date | Mon Feb 22 12:56:46 GMT 2021
- DietPi version | v6.34.3 (MichaIng/master)
- Image creator | DietPi Core Team
- Pre-image | Raspbian Lite
- Hardware | RPi 4 Model B (armv7l) (ID=4)
- Kernel version | Linux DietPi 5.10.11-v7l+ #1399 SMP Thu Jan 28 12:09:48 GMT 2021 armv7l GNU/Linux
- Distro | buster (ID=5,RASPBIAN=1)
- Command | ncc app:install spreed
- Exit code | 1
- Software title | DietPi-Software
User avatar
Joulinar
Posts: 3703
Joined: Sat Nov 16, 2019 12:49 am

Re: Nextcloud 21 released and won't install on dietpi

Post by Joulinar »

Hi,

what version of NextCloud you are running now?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
HelloGoodbye
Posts: 6
Joined: Tue Feb 11, 2020 5:08 am

Re: Nextcloud 21 released and won't install on dietpi

Post by HelloGoodbye »

it's a fresh install of nextcloud through dietpi-software...it's installing v21
User avatar
Joulinar
Posts: 3703
Joined: Sat Nov 16, 2019 12:49 am

Re: Nextcloud 21 released and won't install on dietpi

Post by Joulinar »

I did a test installation and once NextCloud was running I installed Talk without issues

Code: Select all

 DietPi-Software
─────────────────────────────────────────────────────
 Mode: Configuring Nextcloud Talk: Video calls with configured coTURN server

[ INFO ] DietPi-Software | Configuring TURN server:
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: listening-port=3478
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: fingerprint
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: use-auth-secret
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: realm=DietPi3
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: total-quota=100
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: bps-capacity=0
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: stale-nonce
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: no-multicast-peers
[  OK  ] DietPi-Software | systemctl start mariadb
[  OK  ] DietPi-Software | systemctl start redis-server
[  OK  ] DietPi-Software | ncc maintenance:mode --off
[  OK  ] DietPi-Software | ncc app:install spreed
spreed already enabled
Config value stun_servers for app spreed set to ["DietPi3:3478"]
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: static-auth-secret=***
Config value turn_servers for app spreed set to [{"server":"DietPi3:3478","secret":"<OMITTED>","protocols":"udp,tcp"}]
[  OK  ] DietPi-Autostart | systemctl daemon-reload
Pls try to install talk app again. Probably there where some issues at Nextcloud download server side due to the new release. Maybe some overload situation.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
m2m
Posts: 4
Joined: Wed Feb 24, 2021 4:19 pm

Re: Nextcloud 21 released and won't install on dietpi

Post by m2m »

Hello, I have Nextcloud 20.0.7 running on ODROID-C2.
I want to upgrade to 21. But admin/overview says: It is using MariaDB version "10.1.48-MariaDB-0+deb9u1". Nextcloud 21 will not support this version anymore and needs MariaDB 10.2 or higher.
What can I do?
Thank you very much, many greetings!
User avatar
Joulinar
Posts: 3703
Joined: Sat Nov 16, 2019 12:49 am

Re: Nextcloud 21 released and won't install on dietpi

Post by Joulinar »

It seems your are still running Debian Stretch looking to MariaDB version. There you basically have 2 options if you like to use NextCloud 21
  1. update your system to Debian Buster
  2. start a new installation using Debian Buster image
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
m2m
Posts: 4
Joined: Wed Feb 24, 2021 4:19 pm

Re: Nextcloud 21 released and won't install on dietpi

Post by m2m »

Ok, Thank you!
I didn't realize that this would require an upgrade. Let's see what I do.
User avatar
Joulinar
Posts: 3703
Joined: Sat Nov 16, 2019 12:49 am

Re: Nextcloud 21 released and won't install on dietpi

Post by Joulinar »

Even if we do not official support an Debian upgrade, following link might be helpful viewtopic.php?p=18988#p18988

btw, are you sure you are not able to update NextCloud via Web GUI? I did a test installation on Stretch and it was going to install v21 without issues. At least the installation seems to ignore MariaDB 10.1 :lol:
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
m2m
Posts: 4
Joined: Wed Feb 24, 2021 4:19 pm

Re: Nextcloud 21 released and won't install on dietpi

Post by m2m »

Ok, I tried the upgrade and got the allowed memory size exhausted problem.
Probably that:
https://github.com/nextcloud/server/issues/25742
Any ideas?
Next question: How can I get nextcloud to run under php8?
I am using lighttpd.
Thanks a lot!
Post Reply