Analogue audio output gone with v136/JustBoom [SOLVED]

Having issues with your DietPi installation, or, found a bug? Post it here.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by Fourdee »

Sciamano wrote:Analogue audio works for me too, but alsamixer still gives that error. :shock:
Yep, think we did a little whoopsie for v136.

edit /etc/asound.conf and change ctrl.!default to ctl.!default. Save changes, alsamixer should now fire up.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
fhals

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by fhals »

Same here with alsamixer not starting on 137.
My /etc/asound.conf already is ctl'ed:

pcm.!default {
type hw
card 0
device 0
}
ctl.!default {
type hw
card 0
device 0
}
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by Fourdee »

fhals wrote:Same here with alsamixer not starting on 137.
My /etc/asound.conf already is ctl'ed:

pcm.!default {
type hw
card 0
device 0
}
ctl.!default {
type hw
card 0
device 0
}
OrangePi PC? Any chance you can run aplay -l and paste results?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
fhals

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by fhals »

Yes, mine is an OrangePi PC.

This is the result of aplay -l:
**** List of PLAYBACK Hardware Devices ****
card 0: audiocodec [audiocodec], device 0: SUNXI-CODEC sndcodec-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndhdmi [sndhdmi], device 0: SUNXI-HDMIAUDIO sndhdmi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

Regards
Frans
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by Fourdee »

Sciamano wrote:Analogue audio works for me too, but alsamixer still gives that error. :shock:
Yep, it seems to do that with all PCM52xx chips (possibly at kernel level). The following boards all fail to load alsamixer:
- Allo Piano DAC
- JustBoom DAC HAT
- Odroid Hifi Shield 2

Although, amixer appears to work, so you can tweak options with that:

Code: Select all

amixer -c 0 scontrols
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Sciamano
Posts: 264
Joined: Sat Oct 15, 2016 12:18 pm
Location: Italy

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by Sciamano »

Fourdee wrote:
Sciamano wrote:Analogue audio works for me too, but alsamixer still gives that error. :shock:
Yep, it seems to do that with all PCM52xx chips (possibly at kernel level). The following boards all fail to load alsamixer:
- Allo Piano DAC
- JustBoom DAC HAT
- Odroid Hifi Shield 2
I see. Just wanted to make it clear that this is happening on my "naked" Orange Pi PC with no HATs or any other add-on boards.
Not sure if it's related, but I think it should be investigated.
verm71

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by verm71 »

I'm getting this problem on a Raspberry Pi 3, and DietPi 141, where the audio keeps defaulting to HDMI, when I actually want it to go to analog 3.5mm.

My aplay -l output gives me:

Code: Select all

**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
And so my /etc/asound.conf file becomes, to the best of my ability:

Code: Select all

pcm.!default {
    type hw
    card 0
    device 0
}
ctl.!default {
    type hw
    card 0
    device 0
}
but this doesn't seem to solve the problem. Not sure where to go from here.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by Fourdee »

verm71 wrote:I'm getting this problem on a Raspberry Pi 3, and DietPi 141, where the audio keeps defaulting to HDMI, when I actually want it to go to analog 3.5mm.
Hi,

The RPi will default to HDMI if its plugged in, else, 3.5mm analogue is used.

There was a command we could use previously to manually override that, but was removed as it no longer had any effect.

I'll create a ticket and see if we can find a new solution: https://github.com/Fourdee/DietPi/issues/704
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
verm71

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by verm71 »

If I use

Code: Select all

amixer -c 0 cset numid=3 1
followed by

Code: Select all

speaker-test
I get sound come out of my 3.5mm. So that's a good start.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Analogue audio output gone with v136/JustBoom [SOLVED]

Post by Fourdee »

verm71 wrote:If I use

Code: Select all

amixer -c 0 cset numid=3 1
followed by

Code: Select all

speaker-test
I get sound come out of my 3.5mm. So that's a good start.
Thanks Verm,

I'd imagine this needs to be applied during boot, so we'll create a service for this to be applied, when enabled.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply