ip link shows no wifi card (raspberry pi 4 Model B, 2GB) Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
syrillia
Posts: 4
Joined: Wed Oct 28, 2020 8:21 am

ip link shows no wifi card (raspberry pi 4 Model B, 2GB)

Post by syrillia »

Hello everybody,

on my Raspberry Pi 4, Model B 2 GB, is a 802.11b/g/n/ac wireless chip, but i can't see it:

Code: Select all

lspci -nnk

00:00.0 PCI bridge [0604]: Broadcom Limited Device [14e4:2711] (rev 10)
01:00.0 USB controller [0c031]: VIA Technologies, Inc. VL805 USB 3.0 Host Controller [1106:3483] (rev 01)
Subsystem: VIA Technologies, Inc. VL805 USB 3.0 Host Controller [1106:3483]
Kernel driver in use: xhci_hcd

Code: Select all

ip link

1: lo: <loopback> mtu 65536 qdisc noqueue state DOWN mode DEFAULT group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
1: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT grup default qlen 1000 link/ether dc:a6:32:ca:10:0e brd ff:ff:ff:ff:ff:ff

Code: Select all

uname -a

Linux DietPi 5.4.72-v8+ #1356 SMP PREEMPT Thu Oct 22 13:58:52 BST 2020 aarch64 GNU/Linux
I searched a lot, but I could not solve the problem. What is missing? What do I have to install? I read about firmare-update. How is this going on? Please help!
User avatar
Joulinar
Posts: 2597
Joined: Sat Nov 16, 2019 12:49 am

Re: ip link shows no wifi card (raspberry pi 4 Model B, 2GB)

Post by Joulinar »

Hi,

many thanks for your request. Did you tried to activate WiFi within dietpi-config?
  1. dietpi-config > 7 : Network Options: Adapters >
    1. Onboard WiFi : [On]
    2. WiFi : Not Found | [On]
  2. reboot
  3. WiFi status should be WiFi : Available | [On] | Disconnected now
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
syrillia
Posts: 4
Joined: Wed Oct 28, 2020 8:21 am

Re: ip link shows no wifi card (raspberry pi 4 Model B, 2GB)

Post by syrillia »

Thank you! I couldn't see the wood for the trees.
Post Reply