RDP Black Screen Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
danmo117
Posts: 10
Joined: Wed Jun 03, 2020 4:01 pm

Re: RDP Black Screen

Post by danmo117 »

Thanks for the workaround and your time helping.

The black screen is obviously frustrating so do you think it's worth me flashing a clean dietpi img to a spare micro sd card and starting from scratch? If you can't replicate the 5 min black screen I obviously have an incorrect setting somewhere and it could be difficult to locate.

With regards to the other machines I manage, they run Lubuntu with Xrdp installed and when I connect to them from MS RD client it simply logs me in with the stored credentials and displays the desktop. How come I can't replicate this with dietpi?

Thanks.
User avatar
Joulinar
Posts: 2546
Joined: Sat Nov 16, 2019 12:49 am

Re: RDP Black Screen

Post by Joulinar »

ok now I can imagine what happen with the 5 Minutes. You already enter login information into the Win RDP Client? Correct? Because I did not do that. I just open RDP Client and enter the IP Address. User credentials I just specify once xrdp was started. Can you remove login information from RDP client and try again pls.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
danmo117
Posts: 10
Joined: Wed Jun 03, 2020 4:01 pm

Re: RDP Black Screen

Post by danmo117 »

Ahhhhh, yes it displays the xrdp login page straight away and I’m able to log in. I was under the impression that RD credentials were mandatory. Thanks

As for my other question, how is it I can’t have the credentials stored in the RD client and it auto login like I do with the Lununtu machines? Is there anything I can change to achieve this?

-Dan
User avatar
Joulinar
Posts: 2546
Joined: Sat Nov 16, 2019 12:49 am

Re: RDP Black Screen

Post by Joulinar »

yep I found a way around. It looks like xrdp is using the first option Xorg if you enter credentials right from the beginning. Therefore you would need to bring Xvnc in top if the list.

Code: Select all

nano /etc/xrdp/xrdp.ini
hash # all entries for [Xorg] like this (near same location where you changed the port.

Code: Select all

#[Xorg]
#name=Xorg
#lib=libxup.so
#username=ask
#password=ask
#ip=127.0.0.1
#port=-1
#code=20
save the file and restart xrdp service

Code: Select all

systemctl restart xrdp.service
now you should be able to login directly using credentials stored on RDP client.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
danmo117
Posts: 10
Joined: Wed Jun 03, 2020 4:01 pm

Re: RDP Black Screen

Post by danmo117 »

That's it, you've cracked it.

Thanks for helping me out.
Post Reply