apt auto completion not working

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
thiagonatanael
Posts: 1
Joined: Tue May 26, 2020 4:43 pm

apt auto completion not working

Post by thiagonatanael »

I found that a new refreshed install of DietPi does not come with apt auto completion working by default, to throublesoot this do this actions:

Run:
dietpi-config

Then go to:
4 - Advanced Options
APT-Cache

And then:
set the two options (APT cache and APT lists) to [On disk]

After that do:
sudo apt update

Now the command 'sudo apt install ja[TAB][TAB]' will work!
User avatar
Joulinar
Posts: 2617
Joined: Sat Nov 16, 2019 12:49 am

Re: apt auto completion not working

Post by Joulinar »

@MichaIng
Maybe you can have a look. System default is APT cache and APT lists set to [On disk] according the system dialog. However APT cache is set to [Disabled] . Probably it was deactivated to reduce I/O and SD Card usage. But I'm not sure.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply