DietPi-Login DNS Resolver Not Working Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
gamingunfinished
Posts: 9
Joined: Wed Feb 19, 2020 12:06 am

Re: DietPi-Login DNS Resolver Not Working

Post by gamingunfinished »

root@DietPi:~# cat /DietPi/dietpi.txt |grep CONFIG_ENABLE_IPV6
CONFIG_ENABLE_IPV6=0
root@DietPi:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:62:d5:fd brd ff:ff:ff:ff:ff:ff
inet 192.168.1.69/24 brd 192.168.1.255 scope global eth0
valid_lft forever preferred_lft forever
inet6 2606:a000:1408:8269:ba27:ebff:fe62:d5fd/64 scope global dynamic mngtmpaddr
valid_lft 604509sec preferred_lft 604509sec
inet6 fe80::ba27:ebff:fe62:d5fd/64 scope link
valid_lft forever preferred_lft forever
User avatar
Joulinar
Legend
Posts: 8326
Joined: Sat Nov 16, 2019 12:49 am

Re: DietPi-Login DNS Resolver Not Working

Post by Joulinar »

did you reboot your system after you disabled IPv6? If not, pls do. Because you still have an IPv6 address assigned
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
gamingunfinished
Posts: 9
Joined: Wed Feb 19, 2020 12:06 am

Re: DietPi-Login DNS Resolver Not Working

Post by gamingunfinished »

yes, I did. Should I disable ipv6 on my router?
User avatar
Joulinar
Legend
Posts: 8326
Joined: Sat Nov 16, 2019 12:49 am

Re: DietPi-Login DNS Resolver Not Working

Post by Joulinar »

you can try, It's strange that you have IPv6 addresses on your eth0 adaptor

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:62:d5:fd brd ff:ff:ff:ff:ff:ff
inet 192.168.1.69/24 brd 192.168.1.255 scope global eth0
valid_lft forever preferred_lft forever
inet6 2606:a000:1408:8269:ba27:ebff:fe62:d5fd/64 scope global dynamic mngtmpaddr
valid_lft 604509sec preferred_lft 604509sec
inet6 fe80::ba27:ebff:fe62:d5fd/64 scope link
valid_lft forever preferred_lft forever
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
gamingunfinished
Posts: 9
Joined: Wed Feb 19, 2020 12:06 am

Re: DietPi-Login DNS Resolver Not Working

Post by gamingunfinished »

That worked. I'd like to keep ipv6 on though, is there another way to turn it off for the Pi?
User avatar
Joulinar
Legend
Posts: 8326
Joined: Sat Nov 16, 2019 12:49 am

Re: DietPi-Login DNS Resolver Not Working

Post by Joulinar »

you can go to
  1. dietpi-config tool
  2. 7 : Network Options: Adapters
  3. IPv6 : [Off]
this should deactivate IPv6 on your SBC. But this is the same setting as CONFIG_ENABLE_IPV6=0 within dietpi.txt file. If IPv6 was disabled, the command ip a should return an IPv4 address only.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
gamingunfinished
Posts: 9
Joined: Wed Feb 19, 2020 12:06 am

Re: DietPi-Login DNS Resolver Not Working

Post by gamingunfinished »

Thanks for your help
User avatar
Joulinar
Legend
Posts: 8326
Joined: Sat Nov 16, 2019 12:49 am

Re: DietPi-Login DNS Resolver Not Working

Post by Joulinar »

yw 8)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
iDopamin3
Posts: 1
Joined: Mon Dec 14, 2020 2:26 pm

Re: DietPi-Login DNS Resolver Not Working

Post by iDopamin3 »

I made an account just to say thank you, the IPv6 was holding me back!
dvd741
Posts: 2
Joined: Sat Jan 01, 2022 12:50 pm

Re: DietPi-Login DNS Resolver Not Working

Post by dvd741 »

I have the same issue. Sort of... Sometimes.

Ping -c 1 dns9.quad.net

Sometimes gives 100% packet loss.
Sometimes gives 1 received.

Iperf3 to a host on my network runs fine (speeds close to 1Gbps)

Do you have any idea what might be the cause? (Rock Pi 4B 1.72 on Dietpi with kernel 5.10.63)

P.s. IPV6 is disabled and ip a shows no ipv6 ip

Could it be a dns problem? And how should I investigate the cause? :-/
Post Reply