[Resolved] XU4 fails to power on

Having issues with your DietPi installation, or, found a bug? Post it here.
rlamans
Posts: 9
Joined: Thu Jul 07, 2016 9:38 pm

Re: V132 XU4

Post by rlamans »

I noticed the problem way back at v122 (?) and stopped using Dietpi because of it. I have used my cloudshell with OMV, Ubuntu 16.04, and android with no power off problems. If the problem was with the power source you would think the issue would show up with other distros - but it seems to only be a problem with Dietpi. I am back to Dietpi because I love it, but it is not usable without a fix to the power down problem.

I have a cloushell with a 320G HD - the HD was used with the other distros also ...

I tested the power off issue with a clean Dietpi - immediately after file system expansion and no other software installed and experienced the same problem. Hope this helps.
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: V132 XU4

Post by Fourdee »

rlamans wrote:I noticed the problem way back at v122 (?) and stopped using Dietpi because of it. I have used my cloudshell with OMV, Ubuntu 16.04, and android with no power off problems. If the problem was with the power source you would think the issue would show up with other distros - but it seems to only be a problem with Dietpi. I am back to Dietpi because I love it, but it is not usable without a fix to the power down problem.

I have a cloushell with a 320G HD - the HD was used with the other distros also ...

I tested the power off issue with a clean Dietpi - immediately after file system expansion and no other software installed and experienced the same problem. Hope this helps.
Hi,

So just to clarify, the issues you and other users are experiencing are:
1. When you run the command poweroff, the XU4 will not power back on again? Either using the power on button, or, physically reinserting the PSU?
2. When you physically remove the PSU without shutting down, the XU4 fails to power on again?

Can all users who have experienced these issue please list:
- The board revision number/dates on their XU3/4.
- Power supply used (eg 5v/6a)
- SD/EMMC card used and size.
- If you have time, please try installing the following image http://oph.mdrjr.net/meveric/images/Jes ... XU3.img.xz, (username = root, pw = odroid) run apt-get update and apt-get dist-upgrade -y && reboot, then please try to replicate the power on issue you are experiencing (eg: Pull power plug and put back in again, or poweroff)

Also created a Git ticket so we can investigate this: https://github.com/Fourdee/DietPi/issues/558
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
luzifia
Posts: 48
Joined: Tue Jun 28, 2016 9:48 am

Re: XU4 fails to power on

Post by luzifia »

Hi There

As far as i know the last working Image was V130.
Can all users who have experienced these issue please list:
- The board revision number/dates on their XU3/4.
- Power supply used (eg 5v/6a)
- SD/EMMC card used and size.
Power Supply (original one): 5v/4a
XU4 Rev 0.1 20151201
1st Try eMMC: 64GB
2nd Try MircoSD: 16GB
StartImage: DietPi_v127_OdroidXU4-armv7-(Jessie).img
- If you have time, please try installing the following image http://oph.mdrjr.net/meveric/images/Jes ... XU3.img.xz, (username = root, pw = odroid) run apt-get update and apt-get dist-upgrade -y && reboot, then please try to replicate the power on issue you are experiencing (eg: Pull power plug and put back in again, or poweroff)
huch - The Installation takes a while.
Tried on MicroSD 16GB
i've done this and the xu4 reboots. I only can read 6 Lines on the Display the rest seems to be black text-foreground ... but the xu4 react on entered commands (reboot, poweroff).
Luzi
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 fails to power on

Post by Fourdee »

Hi All,

I've recreated the XU4 image for DietPi: https://github.com/Fourdee/DietPi/issue ... -254057278

Could all users who are experiencing power on failures after shutdown, please download the image below and re-test. Thanks.

Image link: http://dietpi.com/downloads/images/Diet ... Jessie).7z
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
rlamans
Posts: 9
Joined: Thu Jul 07, 2016 9:38 pm

Re: XU4 fails to power on

Post by rlamans »

In my case I used the desktop "shutdown" and did not remove the power plug. I also tried to remove the power plug after - but it did not boot.

Also, I used the "poweroff" and "shutdown" commands in terminal with the same results. At no time did I just pull the plug because that is really bad for the XU4 board and SD card.

PS - it appears the link in the post to try a new image is inactive ...
rlamans
Posts: 9
Joined: Thu Jul 07, 2016 9:38 pm

Re: XU4 fails to power on

Post by rlamans »

I tried the RC2 link above after performing an update, upgrade, and reboot ... "poweroff", "shutdown now", and restart via the push button worked as expected.
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 fails to power on

Post by Fourdee »

rlamans wrote:In my case I used the desktop "shutdown" and did not remove the power plug. I also tried to remove the power plug after - but it did not boot.

Also, I used the "poweroff" and "shutdown" commands in terminal with the same results. At no time did I just pull the plug because that is really bad for the XU4 board and SD card.

PS - it appears the link in the post to try a new image is inactive ...
Hi,

We moved the image to live download, new link is http://dietpi.com/downloads/images/Diet ... Jessie).7z, apologies for that.

If you could run the same tests on the image above, i'd be extremely greatful. One of our other users has confirmed the issue is now resolved with that image, but, we'd like to get a few more results before closing this one.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
rlamans
Posts: 9
Joined: Thu Jul 07, 2016 9:38 pm

Re: XU4 fails to power on

Post by rlamans »

Ok, but it will be a couple days ... have to pay the bills!
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 fails to power on

Post by Fourdee »

rlamans wrote:Ok, but it will be a couple days ... have to pay the bills!
No worries, know the feeling ;)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
luzifia
Posts: 48
Joined: Tue Jun 28, 2016 9:48 am

Re: XU4 fails to power on

Post by luzifia »

Hi
Fourdee wrote:Hi,

We moved the image to live download, new link is http://dietpi.com/downloads/images/Diet ... Jessie).7z, apologies for that.

If you could run the same tests on the image above, i'd be extremely greatful. One of our other users has confirmed the issue is now resolved with that image, but, we'd like to get a few more results before closing this one.
Yes it runs with the new Image- tried on MicroSD 16GB.

Fourdee, is there a way now to upgrade my running System V130 to V134 without new Installation?

Luzi
Post Reply