Current Versions of Packages?

Suggestions for features and software you would like to see in DietPi, goes here.
Post Reply
qlander
Posts: 4
Joined: Sun Apr 28, 2019 11:18 am

Current Versions of Packages?

Post by qlander »

Hi there,

Can we get an option to install current versions of packages? I know the DietPi crew mainly focus on stable releases, but can there also be an option to install current versions (dev/beta/'unstable') at the full risk of the owner of the pi?

I have several pi's and I test some packages for load, etc. on rinse&repeat pi setups. Manually setting up new/test packages every time is very time consuming.

I mean, for example, the pi 'stable' version of qbittorrent and deluge is just ridiculous and so out of date is not usable (qbittorrent version is so bad, its dysfunctional - a lot of the issues have been fixed in the latest version, even if not classed as a stable pi release).

I hope this is considered since they'd be benefits for those that want to test newer versions of software on the pi/diet-pi - even have a robust debug/report back to dev feature to gain more support for the platform dietpi runs on.
baz123
Posts: 166
Joined: Thu Jan 12, 2017 9:23 pm

Re: Current Versions of Packages?

Post by baz123 »

I think this is a good idea. I had to install rtl_433 recently from the Rasbian testing repo. I found once I had added the repository, I needed to create a

Code: Select all

/etc/apt/preferences
file so that only that package was updated.

A mechanism to add a repository and set the priority, possibly to also pin a specific package, would be a good addition to DietPi.
User avatar
MichaIng
Site Admin
Posts: 2422
Joined: Sat Nov 18, 2017 6:21 pm

Re: Current Versions of Packages?

Post by MichaIng »

We will not support mixing multiple Debian versions, since this breaks the system in very most cases. E.g. package X from Debian testing repo requires library Y from testing repo. Now all currently installed packages on the system, that depend on library Y from stable repo are either upgraded as well, which is not always wanted, or broken. All scripts that check the installed Debian version to derive required library version will as well get the wrong version now. When forcing install of the old fitting library, all depending packages from testing would be either purged or break the install.

Debian is indeed not a rolling release distro, but one that coounts on stability, with the downside that moreless outdated versions are shipped, especially then the current distro version reaches its 2 years lifetime. However important fixes and security patches are added by the maintainers, very benefitial updates shipped via backports. This btw can be checked to upgrade certain packages safely:
apt install <package_name>/buster-backports
But it only works on non-RPi systems, since Raspbian has no backports repo.

And finally to safely install most current version, where required, I recommend to compile them manually from sources.
Post Reply