Gmediarender disappears from player list

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
dieetilla
Posts: 2
Joined: Sat Nov 10, 2018 7:46 am

Gmediarender disappears from player list

Post by dieetilla »

Sorry for these two consecutive posts, but I didn't feel they could be put together and I'm really struggling with both issues and haven't found any soluion from this forum or elsewhere.

I've been using gmediarender for a few weeks now to stream from JRiver. At times, my dietpi disappears from the list of available players in JRiver or JRemote. Rebooting doesn't help. It seems to come back at its own time. Sometimes it appears for a few seconds, goes away, comes back. This can last a long time. I've never experienced dropout however. Once it's streaming it works well.

Running the command gmediarender seems to fix the issue temporarily. However, then I have two players, one called dietpi and one gmediarender.

The problem seems to appear more often when I haven't used the device in a while or after I use shairport, but there's no clear logic. I'm otherwise really happy with dietpi. What could I be missing? Thanks!
User avatar
MichaIng
Site Admin
Posts: 2281
Joined: Sat Nov 18, 2017 6:21 pm

Re: Gmediarender disappears from player list

Post by MichaIng »

Do you have moved your userdata to an external drive, so possibly spin down/idle could be the reason?

Actually this should only delay response on well programmed software, but found another post where drive idle though a ducking station caused software to fail instead of only wait.
Post Reply