Pi 3b+ not working a week after I added the iuniker dual fan

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
CJ01
Posts: 29
Joined: Sat Jun 23, 2018 12:40 am

Pi 3b+ not working a week after I added the iuniker dual fan

Post by CJ01 »

This isn't related to dietpi but I posted it on raspberrypi.org on July 8,2018 and got 62 views but no replies. I was hoping someone would have some ideas why the pi is dead and maybe how to remove the heatsink/fan module.
I set up a Pi 3B+ as a router back in March 2018. I had same setup on a Pi3B that was running fine for 2 plus years with no issues and only heatsinks. Well I decided to switch the micro card to the 3B+ but of course it did not boot since the OS was not compatible. So I flashed the newest of Raspbian , installed the code and changes for the router config and the new 3B+ was working fine. I didn't have any overheating issues but decided to put on the new dual fan system from Iuniker made for the 3B+.
This worked for I guess about 2 weeks and I went to upgrade my Pi's last week. (I have many small projects on Pi Zero, pi Zero W, Pi3B and this new Pi3B+) and could not SSH or VNC into the 3B+.
So I checked on it and the only light that was on was the Red led and the fan was still running. No green activity light and the ethernet lights were not flashing.
I found it strange the Pi was not running but the fan was. I unplugged the pi. Waited a minute and plugged the power back in. Only the Red led came on and the fan.
The green light didn't even flash once. So I tried everything. Unplugged the fan. A power supply (I uses 5V with 2.5 or 3 amps) I know is working from another Pi3B. Also when I plug the bad Pi (power) in only the red led comes on. The green led does not even flicker for a moment. I replaced the card with a fresh image of the OS. Still nothing.
I have another Pi3B+. I took the card and power supply from the bad pi and put it in the new one and all is ok and working on the 2nd 3B+.

So is my 3B+ fried? Why does the fan come on and nothing else? How do I check? Also do I return the unit to Microcenter where I purchased it? How do I remove the fan/heatsink? Could that have caused issues? If It shorted I would think it would not take over 2 weeks to stop working.
I'm also worried if I put the heat sink/dual fan on my newest 3B+ it may cause the same issues.
I also saw someone on youtube who said to pull and reseat the connector above the sdcard as that has cause him issues in the past. But it didn't fix the problem.
Any help would be appretiated.
User avatar
WarHawk
Posts: 606
Joined: Thu Jul 20, 2017 8:55 am

Re: Pi 3b+ not working a week after I added the iuniker dual fan

Post by WarHawk »

Does it recognize the card if you put it in an adapter and insert it in a windows machine?
Do you have a linux machine that you can put it in and run a gparted check partition command on?

Could be crappy SD cards...there really are a bunch of shady people out there selling crap as "good"

A fan should not kill a RPi...in fact it should help..it removes heat...did you artic silver epoxy it down?
Did you do any heat monitoring after you put it on to see if it was actually cooling or if it was still running hot

What kind of power are you feeding your RPi, cheap phone chargers can sometimes make crappy dc voltage with alot of ripple in them, and are you using a thin cord or a thick one (electrical losses can be quite high in normal phone charging cables)

There is alot we aren't getting

Pics?
CJ01
Posts: 29
Joined: Sat Jun 23, 2018 12:40 am

Re: Pi 3b+ not working a week after I added the iuniker dual fan

Post by CJ01 »

If you read my entire thread I say I use 5v (2.5 to 3.0 AMP) power supplies. In fact I made sure I use a 5v 3.0 Amp supply on the new 3B+ that I have. Also When I switched the card and power supply to another 3B+ it works on that Pi without an issue.
And yes I did to heat sink monitoring after I put it on to see if it kept cool. Plus I ran the stress test. And the first thing I did was out the card in an adapter and put it on a windows pc to see if it was recognized.
So I think I answered all the questions you had!
User avatar
WarHawk
Posts: 606
Joined: Thu Jul 20, 2017 8:55 am

Re: Pi 3b+ not working a week after I added the iuniker dual fan

Post by WarHawk »

Sounds like that Pi3 might be kaput then
CJ01
Posts: 29
Joined: Sat Jun 23, 2018 12:40 am

Re: Pi 3b+ not working a week after I added the iuniker dual fan

Post by CJ01 »

First time ever I had a Pi die on me.
Services to be held soon!
CJ01
Posts: 29
Joined: Sat Jun 23, 2018 12:40 am

Re: Pi 3b+ not working a week after I added the iuniker dual fan

Post by CJ01 »

Just for kicks, I used alcohol and a exacto (razor) to remove the fan and the other heatsinks. First I used a
magnifying glass to make sure nothing was shorting out metal to metal. Also there was no melting of the adhesive tape
that could be shorted. Waited a day and the Pi still wouldn't start.
I have my other 3B+ running for over 4 weeks with no fan or heatsink. I hesitate to add another iuniker dual fan to this one.
If I do and it dies I would assume there is an issue with the iuniker unit.Or I may start with just the dual fan and wait a month and
add each heatsink and wait a few weeks in between.
Post Reply