Samba Client Issues [SOLVED]

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
bookedirl
Posts: 25
Joined: Sat Oct 24, 2015 7:15 am

Samba Client Issues [SOLVED]

Post by bookedirl »

Hello,

I've been running DietPi for awhile with no issues. Recently, I think after I updated to version 6.6 (I think?) my Plex server is having issues connecting to the Samba client which has all my media files on it. I verified I can access them on my PC so I know they're not dead. How would I go about troubleshooting this? I don't see any errors when I go to add in the info for it (which hasn't changed and it was working previously) is there a way I can see the error that is causing it not to connect?

I tried uninstalling the samba client > Rebooting > Reinstalling and it still won't connect. In dietpi-config under NAS it says Samba Client: Unable to connect and/or incorrect details, which I know it's not the incorrect details.

Thank you.
Last edited by bookedirl on Tue Apr 10, 2018 12:55 am, edited 1 time in total.
User avatar
k-plan
Posts: 416
Joined: Sun Feb 28, 2016 5:28 pm

Re: Samba Client Issues

Post by k-plan »

Hello,

out of concern, which device have you running the samba client please? RPi? Odroid?

Samba server with your files, is running on what? RPi, OpenWRT, Fritzbox, Router, FreeNAS, Synologie NAS, Windows 2013 Server ...?
bookedirl wrote:In dietpi-config under NAS it says Samba Client: Unable to connect and/or incorrect details, which I know it's not the incorrect details.
Please have a look:

http://dietpi.com/phpbb/viewtopic.php?f=11&t=3030

http://dietpi.com/phpbb/viewtopic.php?f ... 004#p11600

https://github.com/Fourdee/DietPi/issues/1693

bookedirl wrote:Recently, I think after I updated to version 6.6 (I think?)
Don't think it is a problem with DietPi updates. More with updating baseline distro, which is now automated running before dietpi-update since v6.3 https://github.com/Fourdee/DietPi/blob/ ... G.txt#L114

Think you will have a newer samba version running now, installed by apt-get update and your server a outdated version.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
bookedirl
Posts: 25
Joined: Sat Oct 24, 2015 7:15 am

Re: Samba Client Issues

Post by bookedirl »

Sorry, this is a Raspberry PI 3. My Nas is a MyCloud Duo. I typically connect using the IP (192.168.1.38 in my case) followed by the share name and then log in credentials.

This was all working fine previously so I'm not sure what happened. I don't typically do anything else on here except occasionally check for DietPi updates.

I just set up a new install of DietPi and installed Plex and Samba Client. The same issue is still there. It won't connect to my NAS. I have another raspberry pi but hasn't been updated to the latest version of DietPi and that currently has no issues Logging in to the same NAS with the same log in info.
bookedirl
Posts: 25
Joined: Sat Oct 24, 2015 7:15 am

Re: Samba Client Issues

Post by bookedirl »

Thanks for the links, I was able to follow one of the sub links in a thread that said to add vers=1.0 to my samba share. Thanks again.


http://dietpi.com/phpbb/viewtopic.php?f ... mba#p11600
Post Reply