Turning off sleep modes

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Hans
Posts: 6
Joined: Mon Jan 29, 2018 1:47 am

Turning off sleep modes

Post by Hans »

I am pretty much a n00b even though I have been working at learning linux on and off for many years. In other words, my skill level is novice.

I have been working with DietPi on a Raspberry Pi Zero W. What I am currently doing is running a very low priority, in house/self-hosted, Wordpress server. It works very well except that the Pi seems to go into a sleep mode after a long period of inactivity. I cannot wake it with keyboard. I cannot reach it via SSH. I cannot reach it via HTTP. I am connecting via the internal WiFi adapter and do have BT enabled. My keyboard is a wired USB keyboard and no mouse.

It might be two separate issues: screen blanking and deep sleep.

I have done quite a bit of reading but haven't been successful.

What is the definitive answer for how to turn off screen blanking permanently?
How can I turn off any and all sleep modes?

I'm liking DietPi so far. Thanks in advance.
User avatar
k-plan
Posts: 416
Joined: Sun Feb 28, 2016 5:28 pm

Re: Turning off sleep modes

Post by k-plan »

Hi,
Hans wrote:I am connecting via the internal WiFi adapter
You have to enable "auto reconnect" under "WiFi settings" in dietpi-config.
But your default gateway (router) must answer on "ping". Please check it.

Powersaving for WiFi card is disable by default.
Hans wrote:screen blanking
On hdmi output:
http://dietpi.com/phpbb/viewtopic.php?f ... 1555#p1555
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
Hans
Posts: 6
Joined: Mon Jan 29, 2018 1:47 am

Re: Turning off sleep modes

Post by Hans »

k-plan wrote:You have to enable "auto reconnect" under "WiFi settings" in dietpi-config.
But your default gateway (router) must answer on "ping". Please check it.
I forgot to set that after re-imaging this last time. Thanks.
That is the main thread that frustrated me. (Others, like on the Raspberry Pi forum too.) /etc/kbd/config doesn't exist. Indeed, /etc/kbd doesn't exist either.
Hans
Posts: 6
Joined: Mon Jan 29, 2018 1:47 am

Re: Turning off sleep modes

Post by Hans »

Hans
Posts: 6
Joined: Mon Jan 29, 2018 1:47 am

Re: Turning off sleep modes

Post by Hans »

I noticed that there was a new DietPi image so I backed up the Wordpress site and set the system up again. There are no sleep problems except for screen blanking; it keeps pulling up HDMI2 on my monitor when I access the site after screen blanks. That gets quite annoying when I'm using my desktop on HDMI1. :lol: I haven't tried a fix yet but I think the screen fix from my previous post will work.
Hans
Posts: 6
Joined: Mon Jan 29, 2018 1:47 am

Nope, still unreachable after a while.

Post by Hans »

Well, the screen blank problem is solved. After a while, I can log into the Pi directly but cannot access it via SSH or HTTP.

It seems to happen when the DHCP lease runs out. I needed static local IP so I set that. Now, I had a time when the interface had two IP addresses after the initial lease was up. One was the dynamic IP and the other was the static IP. When I checked no-ip (I am NOT yet using the web URL, this is all 192.168.0.xxx right now), it showed two wlan interfaces! I rebooted and that issue disappeared. Throughout all of this, I could do the internet connectivity test in dietpi-config. It had internet connectivity.

A little help? I am stumped. :?
Hans
Posts: 6
Joined: Mon Jan 29, 2018 1:47 am

Re: Turning off sleep modes

Post by Hans »

The only remaining issue is that when the system sits for a half-day to a day, it is not accessible via WiFi. It doesn't matter if I log back in on keyboard. The only thing that will bring it back online is to reset WiFi on the Raspberry Pi Zero W.

I will try a search this week for that exact issue. With this problem, DietPi is unusable for my needs. I really hope it can be solved.

Does anyone know a fix?
Post Reply