Trouble with compiling Squid from source...

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
skyfly555
Posts: 81
Joined: Tue Nov 17, 2015 12:16 pm

Trouble with compiling Squid from source...

Post by skyfly555 »

Hello,
I'm tying to compile Squid from source as explained in the article http://blog.diladele.com/2014/01/02/web ... pberry-pi/ because I'm trying to have a Wheezie DietPi Squid Server with HTTPS/SSL support using Diladele Web Safety.

It seems to work but when I get to the instruction:

Code: Select all

dpkg-buildpackage -rfakeroot -b
I get an error message saying I'm root and so on.

I'm SSHing to my RPi 2 and by default on DietPi I get into my RPi as root, I wonder if I can do something to not to be "root" because I think trouble I'm having with -rfakerrot it's related to that.

I suppose the answer is very simple, but I'm a Linux Server newbie (tons of experience with Ubuntu as workstation, but no experience using Debian-Raspbian Server), so I don't know how to do it on DietPi (some time ago I installed Official Minimal Jessie Image and I realised I went into the RPi as user, and had to sudo to use RPi as root from SSH, but I don't know how to do this - sudo & unsudo) under DietPi).

Thank you very much,
User avatar
Fourdee
Site Admin
Posts: 2783
Joined: Tue Feb 06, 2007 1:36 pm

Re: Trouble with compiling Squid from source...

Post by Fourdee »

skyfly555 wrote:I get an error message saying I'm root and so on.
Any chance you could copy/paste the error/s? I'll take a look and see if I can provide any help.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
skyfly555
Posts: 81
Joined: Tue Nov 17, 2015 12:16 pm

Re: Trouble with compiling Squid from source...

Post by skyfly555 »

Thank you for your help, Fourdee.

I've e-mailed to Quintolabs, creators of Diladele Web Safety, and they've said they will give me the instructions to do it under Raspbian Jessie, because maybe the error can be due to the instructions they gave in the post i told you about are out-of-date.

I'll keep you informed when I receive an answer from them.

Equally, I've read that for security reasons it's a good idea to have SSH enabled with a non-root user and then, when you got into your RPi, make sudo; this is important, especially when you have NoIP Service active; I wonder if it's possible under DietPi to create a non-root user to SSH into RPi, and if it has to be done from terminal or in the config files of OpenSSH/Dropbear. I'm just interested in knowing this, if possible, although not extremely worried about this :)
User avatar
Fourdee
Site Admin
Posts: 2783
Joined: Tue Feb 06, 2007 1:36 pm

Re: Trouble with compiling Squid from source...

Post by Fourdee »

skyfly555 wrote:Equally, I've read that for security reasons it's a good idea to have SSH enabled with a non-root user and then, when you got into your RPi, make sudo; this is important, especially when you have NoIP Service active;
Both placebos.
Your network router will block external access through tcp port 21 (ssh) by default. You would need to enable port forwarding, before external ssh access is possible.
In terms of damage, a non-root user running sudo is no different to a root user.


You can disable OpenSSH Server root SSH login by running:

Code: Select all

sed -i '/PermitRootLogin/c\PermitRootLogin no' /etc/ssh/sshd_config 
systemctl restart ssh
service ssh restart for wheezy
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
skyfly555
Posts: 81
Joined: Tue Nov 17, 2015 12:16 pm

Re: Trouble with compiling Squid from source...

Post by skyfly555 »

Thanks for answering. Thinking on it, they are really placebos. Nothing's better than closed ports :)
Post Reply