NanoPi NEO 2 v150 to v151 update fail

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Magno99900
Posts: 5
Joined: Sun May 21, 2017 8:41 am

NanoPi NEO 2 v150 to v151 update fail

Post by Magno99900 »

Hey, Still kinda new to this so any help would be appreciated.

Have tried multiple times updating from v150 to v151 and each time is unsuccessful.

Code: Select all

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (6) Could not resolve host: dietpi.com
 [Failed] Download failed, unable to run update. Please try running dietpi-update again.
That is the error i keep getting each time. Any advice?
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: NanoPi NEO 2 v150 to v151 update fail

Post by Fourdee »

Looks like a DNS issue with your network.

Can you ping any of the following from system?

Code: Select all

ping -c 1 dietpi.com
ping -c 1 fuzon.co.uk
ping -c 1 google.com
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Magno99900
Posts: 5
Joined: Sun May 21, 2017 8:41 am

Re: NanoPi NEO 2 v150 to v151 update fail

Post by Magno99900 »

I'm able to ping all 3 until i run 'dietpi-update', once that command is run i'm unable to ping any of them.
rothchild
Posts: 74
Joined: Sat Jun 27, 2015 10:39 am

Re: NanoPi NEO 2 v150 to v151 update fail

Post by rothchild »

Are you running pi-hole on this box? I find I have the same issue on my Neo1 which is running pihole, have to revert to using DNS from my router to get it to update.
Magno99900
Posts: 5
Joined: Sun May 21, 2017 8:41 am

Re: NanoPi NEO 2 v150 to v151 update fail

Post by Magno99900 »

rothchild wrote:Are you running pi-hole on this box? I find I have the same issue on my Neo1 which is running pihole, have to revert to using DNS from my router to get it to update.
Yes I am, it seems as though it's stopping all the processes before it tries to download anything.

*update* switched from static ip to dhcp and uninstalled pihole, update worked no problems.
rothchild
Posts: 74
Joined: Sat Jun 27, 2015 10:39 am

Re: NanoPi NEO 2 v150 to v151 update fail

Post by rothchild »

Magno99900 wrote:
rothchild wrote:Are you running pi-hole on this box? I find I have the same issue on my Neo1 which is running pihole, have to revert to using DNS from my router to get it to update.
*update* switched from static ip to dhcp and uninstalled pihole, update worked no problems.
Ahh, neat! I've got a big backup job running right now, which I don't want to risk, but when it's done I'll be giving that a go.
rothchild
Posts: 74
Joined: Sat Jun 27, 2015 10:39 am

Re: NanoPi NEO 2 v150 to v151 update fail

Post by rothchild »

It seems it's the 'uninstall pi-hole' bit that makes this work not the change from static to DHCP (all my other devices update fine even though they're set to static).

Looks like I'm still on the rigmarole of resetting DNS to the router, updating the pihole box and then setting DNS back to the pihole. :-(
SubNoize
Posts: 7
Joined: Wed Mar 30, 2016 5:40 am

Re: NanoPi NEO 2 v150 to v151 update fail

Post by SubNoize »

this is failing on my pi. I uninstalled PiHole but i'm still getting the issues.
Post Reply