Update from 148 to 149 does not work

Having issues with your DietPi installation, or, found a bug? Post it here.
dietpiOK
Posts: 80
Joined: Thu Mar 16, 2017 9:33 am

Update from 148 to 149 does not work

Post by dietpiOK »

Hi,

I tried to update my raspi from dietpi 148 to 149 by using "dietpi-update". A lot happens and finally the update process asks me to reboot.
After the reboot the system still says that I can update from 148 to 149.

I tried it several times but always the same.

What can I do?

Best regards,
Olaf
dietpiOK
Posts: 80
Joined: Thu Mar 16, 2017 9:33 am

Re: Update from 148 to 149 does not work

Post by dietpiOK »

@Fourdee: Do you have any advise on how to get the update running?
User avatar
Fourdee
Site Admin
Posts: 2783
Joined: Tue Feb 06, 2007 1:36 pm

Re: Update from 148 to 149 does not work

Post by Fourdee »

Hi,

Please paste results:

Code: Select all

df -h
systemctl status dietpi-ramdisk -l
And, during the update, do you notice any on screen errors?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
dietpiOK
Posts: 80
Joined: Thu Mar 16, 2017 9:33 am

Re: Update from 148 to 149 does not work

Post by dietpiOK »

Code: Select all

root@maschine2:~# df -h
Filesystem             Size  Used Avail Use% Mounted on
/dev/root               15G  1.7G   13G  12% /
devtmpfs               459M     0  459M   0% /dev
tmpfs                  463M     0  463M   0% /dev/shm
tmpfs                  463M   24M  440M   6% /run
tmpfs                  5.0M  4.0K  5.0M   1% /run/lock
tmpfs                  463M     0  463M   0% /sys/fs/cgroup
tmpfs                   10M  1.2M  8.9M  12% /DietPi
tmpfs                   20M   36K   20M   1% /var/log
tmpfs                  463M     0  463M   0% /tmp
/dev/mmcblk0p1          60M   23M   38M  38% /boot
192.168.97.222:/raspi  1.8T  909G  924G  50% /mnt/nas
root@maschine2:~# systemctl status dietpi-ramdisk -l
● dietpi-ramdisk.service - DietPi-RAMdisk
   Loaded: loaded (/etc/systemd/system/dietpi-ramdisk.service; enabled)
   Active: active (exited) since Thu 2017-05-04 03:17:10 CEST; 3 weeks 6 days ago
  Process: 600 ExecStart=/bin/bash -c /boot/dietpi/dietpi-ramdisk 0 &>> /etc/dietpi/logs/dietpi-ramdisk.log (code=exited, status=0/SUCCESS)
  Process: 572 ExecStartPre=/bin/mkdir -p /etc/dietpi/logs (code=exited, status=0/SUCCESS)

May 04 03:17:10 maschine2 systemd[1]: Started DietPi-RAMdisk.
root@maschine2:~#
No, I did not see any error messages.
User avatar
Fourdee
Site Admin
Posts: 2783
Joined: Tue Feb 06, 2007 1:36 pm

Re: Update from 148 to 149 does not work

Post by Fourdee »

Thanks. Looks ok. Lets try updating and forcing ramdisk to save (instead of during shutdown phase).

Please try running the update:

Code: Select all

dietpi-update
Then forcing saving RAMdisk:

Code: Select all

systemctl stop dietpi-ramdisk
Check successful with (should return 150):

Code: Select all

cat /boot/dietpi/.version
If ok, reboot system and check login reports v150.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
dietpiOK
Posts: 80
Joined: Thu Mar 16, 2017 9:33 am

Re: Update from 148 to 149 does not work

Post by dietpiOK »

Thanks for your support!
The results are:

Before reboot it shows version 150.
After reboot it shows version 148.

:(
dietpiOK
Posts: 80
Joined: Thu Mar 16, 2017 9:33 am

Re: Update from 148 to 149 does not work

Post by dietpiOK »

It is the same behaviour for the new update to 151 :(
kami
Posts: 26
Joined: Thu Jun 01, 2017 3:07 pm

Re: Update from 148 to 149 does not work

Post by kami »

Hi,

i have got the same problem with 148 to 150 and now to 151.

Always the same with Reboot to 148. But after i did this :

systemctl stop dietpi-ramdisk

Everything works fine.

Thanks a lot.

Cu kami
dietpiOK
Posts: 80
Joined: Thu Mar 16, 2017 9:33 am

Re: Update from 148 to 149 does not work

Post by dietpiOK »

You disabled the ramdisk before running the dietpi-update command?
kami
Posts: 26
Joined: Thu Jun 01, 2017 3:07 pm

Re: Update from 148 to 149 does not work

Post by kami »

No, after the update.
Post Reply