XU4 Kodi no screen found

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
mims
Posts: 12
Joined: Wed Mar 15, 2017 7:52 am

XU4 Kodi no screen found

Post by mims »

Hello,

I'm running dietpi headless on my Odroid XU4.
I wanted to run kodi but...

1.

Code: Select all

root@odroid:~# kodi
ERROR: Unable to create GUI. Exiting
Segmentation fault
Crash report available at /root/kodi_crashlog-20170419_204135.log

Code: Select all

############## Kodi CRASH LOG ###############

################ SYSTEM INFO ################
 Date: Wed 19 Apr 20:41:35 CEST 2017
 Kodi Options: 
 Arch: armv7l
 Kernel: Linux 3.10.104+ #1 SMP PREEMPT Tue Feb 21 14:20:54 CET 2017
 Release: Debian GNU/Linux 8 (jessie)
############## END SYSTEM INFO ##############

############### STACK TRACE #################
gdb not installed, can't get stack trace.
############# END STACK TRACE ###############

################# LOG FILE ##################

20:41:35 T:2950565888  NOTICE: special://profile/ is mapped to: special://masterprofile/
20:41:35 T:2950565888  NOTICE: -----------------------------------------------------------------------
20:41:35 T:2950565888  NOTICE: Starting Kodi from Debian (16.1 Debian package version: 16.1+dfsg1-2~bpo8+1). Platform: Linux ARM (Thumb) 32-bit
20:41:35 T:2950565888  NOTICE: Using Release Kodi from Debian x32 build
20:41:35 T:2950565888  NOTICE: Kodi from Debian compiled from 16.1+dfsg1-2~bpo8+1 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.36 (200740)
20:41:35 T:2950565888  NOTICE: Running on Debian GNU/Linux 8 (jessie), kernel: Linux ARM 32-bit version 3.10.104+
20:41:35 T:2950565888  NOTICE: FFmpeg version: 3.1.3-1~bpo8+1
20:41:35 T:2950565888  NOTICE: Host CPU: ARMv7 Processor rev 3 (v7l), 8 cores available
20:41:35 T:2950565888  NOTICE: ARM Features: Neon disabled
20:41:35 T:2950565888  NOTICE: special://xbmc/ is mapped to: /usr/share/kodi
20:41:35 T:2950565888  NOTICE: special://xbmcbin/ is mapped to: /usr/lib/arm-linux-gnueabihf/kodi
20:41:35 T:2950565888  NOTICE: special://masterprofile/ is mapped to: /root/.kodi/userdata
20:41:35 T:2950565888  NOTICE: special://home/ is mapped to: /root/.kodi
20:41:35 T:2950565888  NOTICE: special://temp/ is mapped to: /root/.kodi/temp
20:41:35 T:2950565888  NOTICE: The executable running is: /usr/lib/arm-linux-gnueabihf/kodi/kodi.bin
20:41:35 T:2950565888  NOTICE: Local hostname: mims-droid
20:41:35 T:2950565888  NOTICE: Log File is located: /root/.kodi/temp/kodi.log
20:41:35 T:2950565888  NOTICE: -----------------------------------------------------------------------
20:41:35 T:2950565888   ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
20:41:35 T:2950565888  NOTICE: load settings...
20:41:35 T:2950565888   ERROR: PulseAudio: Failed to connect context
20:41:35 T:2950565888  NOTICE: PulseAudio might not be running. Context was not created.
20:41:35 T:2950565888  NOTICE: Found 1 Lists of Devices
20:41:35 T:2950565888  NOTICE: Enumerated ALSA devices:
20:41:35 T:2950565888  NOTICE:     Device 1
20:41:35 T:2950565888  NOTICE:         m_deviceName      : @
20:41:35 T:2950565888  NOTICE:         m_displayName     : Default (odroid-audio Analog)
20:41:35 T:2950565888  NOTICE:         m_displayNameExtra:
20:41:35 T:2950565888  NOTICE:         m_deviceType      : AE_DEVTYPE_PCM
20:41:35 T:2950565888  NOTICE:         m_channels        : FL,FR
20:41:35 T:2950565888  NOTICE:         m_sampleRates     : 8000,11025,16000,22050,32000,44100,48000,64000,88200,96000,176400,192000
20:41:35 T:2950565888  NOTICE:         m_dataFormats     : AE_FMT_S24NE4,AE_FMT_S16NE,AE_FMT_S16LE
20:41:35 T:2950565888  NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
20:41:35 T:2950565888  NOTICE: No settings file to load (special://masterprofile/advancedsettings.xml)
20:41:35 T:2950565888  NOTICE: Default DVD Player: dvdplayer
20:41:35 T:2950565888  NOTICE: Default Video Player: dvdplayer
20:41:35 T:2950565888  NOTICE: Default Audio Player: paplayer
20:41:35 T:2950565888  NOTICE: Disabled debug logging due to GUI setting. Level 0.
20:41:35 T:2950565888  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"
20:41:35 T:2950565888  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
20:41:35 T:2950565888  NOTICE: Loaded playercorefactory configuration
20:41:35 T:2950565888  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
20:41:35 T:2950565888  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
20:41:35 T:2950565888  NOTICE: Running database version Addons20
20:41:35 T:2950565888  NOTICE: ADDONS: Using repository repository.xbmc.org
20:41:35 T:2950565888   ERROR: GLX Error: No Display found
20:41:35 T:2950565888   FATAL: CApplication::Create: Unable to init windowing system


############### END LOG FILE ################

############ END Kodi CRASH LOG #############
2.

Code: Select all

root@odroid:~# xinit /usr/bin/kodi --standalone -- -nocursor :0


X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-0.bpo.4-armmp-lpae armv7l Debian
Current Operating System: Linux mims-droid 3.10.104+ #1 SMP PREEMPT Tue Feb 21 14:20:54 CET 2017 armv7l
Kernel command line: console=tty1 root=/dev/mmcblk0p2 rootwait ro fsck.repair=yes drm_kms_helper.edid_firmware=edid/1920x1080.bin smsc95xx.macaddr=00:1e:06:61:7a:72 governor=performance hdmi_tx_amp_lvl=31 hdmi_tx_lvl_ch0=3 hdmi_tx_lvl_ch1=3 hdmi_tx_lvl_ch2=3 hdmi_tx_emp_lvl=6 hdmi_clk_amp_lvl=31 hdmi_tx_res=0 HPD=true vout=hdmi
Build Date: 11 February 2015  01:18:06AM
xorg-server 2:1.16.4-1 (http://www.debian.org/support) 
Current version of pixman: 0.32.6
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 19 20:44:38 2017
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Parse error on line 26 of section Monitor in file /usr/share/X11/xorg.conf.d/xorg.conf
	This section must have an Identifier line.
(EE) 
Fatal server error:
(EE) no screens found(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.

Code: Select all

Same output than 1.
3. And for fun

Code: Select all

root@odroid:~# xrandr
Can't open display
The XU4 is of course plugged in into my TV :D

I've reinstalled kodi, xserver-xorg* but it had no effect.

I want to see my moviesssssss... :D
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 Kodi no screen found

Post by Fourdee »

(EE) no screens found(EE)
Hi,
I'm running dietpi headless on my Odroid XU4.
I wanted to run kodi but...

The XU4 is of course plugged in into my TV
Thats not headless ;)

Lets try reinstalling xserver, please report any errors:

Code: Select all

dietpi-software reinstall 6
Correct way to launch is with xinit:

Code: Select all

xinit kodi-standalone
If your trying to launch kodi via SSH, you "may" need a redirect:

Code: Select all

xinit kodi-standalone &> /dev/tty1
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
mims
Posts: 12
Joined: Wed Mar 15, 2017 7:52 am

Re: XU4 Kodi no screen found

Post by mims »

Hi Fourdee,

Thanks for the reply.
I performed the commands without any error.
Kodi starts but I have a black screen. I can 'hear' Kodi menu when pressing arrow keys. Could you guide me to resolve this please?

Thanks
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 Kodi no screen found

Post by Fourdee »

mims wrote:Hi Fourdee,

Thanks for the reply.
I performed the commands without any error.
Kodi starts but I have a black screen. I can 'hear' Kodi menu when pressing arrow keys. Could you guide me to resolve this please?

Thanks
Thanks for the info.

I'll create a ticket and see if we can replicate this issue:
https://github.com/Fourdee/DietPi/issues/893

If you could also send us a bug report, i'd be extremely grateful. We can use this to check for installed software/packages and DietPi settings:
http://dietpi.com/phpbb/viewtopic.php?f=8&t=499#p2184
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply