Orange Pi Zero setup and running - not

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
scargill
Posts: 16
Joined: Sat Oct 15, 2016 11:03 pm

Orange Pi Zero setup and running - not

Post by scargill »

The Orange Pi Zero - finally got my hands on one - and while setting up headlessly with hardware Internet proved fine, wireless has proven hopeless.

I had several attempts, flashing an SD and filling in the details in the text file to set up the WIFI - no. Eventually I booted into the machine using hardwired Ethernet and went through the WIFI settings in dietpi-config - at one point it found the WIFI - but next time I went in the settings were gone - when I eventually got the settings running, it was fine until reboot and would not start up in WIFI again. This is using the internal wifi on the board so it's not some flakey plug-in WIFI adaptor. WIRED - fine, reliable - WIRELESS - no - and I do test lots of boards both wired and wifi. I have the aerial plugged in.

Something wrong there.
User avatar
Fourdee
Site Admin
Posts: 2787
Joined: Tue Feb 06, 2007 1:36 pm

Re: Orange Pi Zero setup and running - not

Post by Fourdee »

Hi Peter,

We use ARMbian to build this image. This includes the kernel, firmware and modules used by the board and therefor, onboard WiFi.

I did find issues with onboard WiFi during my tests aswell, please try this workaround and let us know if it resolves:
Copy and paste all into terminal/ssh.
https://github.com/Fourdee/DietPi/issue ... -266006050
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply