HTTP ERROR 599 after upgrade

Having issues with your DietPi installation or found a bug? Post it here.
Fabio
Posts: 38
Joined: Fri Dec 18, 2020 2:43 pm

HTTP ERROR 599 after upgrade

Post by Fabio »

Hello all, after the last upgrade, if i run

Code: Select all

diepi-services status
everuthing is ok, but i get back the error in the title.
Someone knows how to solve this situation?

Thanks for the support!
User avatar
Joulinar
Posts: 5096
Joined: Sat Nov 16, 2019 12:49 am

Re: HTTP ERROR 599 after upgrade

Post by Joulinar »

Hi,

can you share some more information. Where do you have this error message? On wich application?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Fabio
Posts: 38
Joined: Fri Dec 18, 2020 2:43 pm

Re: HTTP ERROR 599 after upgrade

Post by Fabio »

I'm getting the error via browser and also via the PC( Windows ) application
Thx for the support, if you need further infos, let me know!
User avatar
Joulinar
Posts: 5096
Joined: Sat Nov 16, 2019 12:49 am

Re: HTTP ERROR 599 after upgrade

Post by Joulinar »

still, what are you trying to do? What application you are trying to access?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Fabio
Posts: 38
Joined: Fri Dec 18, 2020 2:43 pm

Re: HTTP ERROR 599 after upgrade

Post by Fabio »

I'm trying to access OwnCloud, sorry i've forgot that little detail :roll:
Everything was working properly before the updates...
User avatar
Joulinar
Posts: 5096
Joined: Sat Nov 16, 2019 12:49 am

Re: HTTP ERROR 599 after upgrade

Post by Joulinar »

are you able to reach your web server directly just using the IP address? let's check as well LISTEN ports on your system

Code: Select all

ss -tulpn | grep LISTEN
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Fabio
Posts: 38
Joined: Fri Dec 18, 2020 2:43 pm

Re: HTTP ERROR 599 after upgrade

Post by Fabio »

Hello @Joulinar this is what i've get:

Code: Select all

tcp     LISTEN   0        511            127.0.0.1:6379          0.0.0.0:*       users:(("redis-server",pid=511,fd=7))                                          
tcp     LISTEN   0        1024             0.0.0.0:80            0.0.0.0:*       users:(("lighttpd",pid=668,fd=4))                                              
tcp     LISTEN   0        1000             0.0.0.0:22            0.0.0.0:*       users:(("dropbear",pid=487,fd=3))                                              
tcp     LISTEN   0        511                [::1]:6379             [::]:*       users:(("redis-server",pid=511,fd=8))                                          
tcp     LISTEN   0        1024                [::]:80               [::]:*       users:(("lighttpd",pid=668,fd=5))                                              
tcp     LISTEN   0        1000                [::]:22               [::]:*       users:(("dropbear",pid=487,fd=4))  
Any ideas?
User avatar
Joulinar
Posts: 5096
Joined: Sat Nov 16, 2019 12:49 am

Re: HTTP ERROR 599 after upgrade

Post by Joulinar »

ok lighttpd web server seems to be running. What happen of you just try to access the server by http://192.168.x.x ? Does it give anything? As well pls can you share web server document root ls -la /var/www/

As well I'm missing the data base process on your output. pls can you share systemctl status mariadb.service
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Fabio
Posts: 38
Joined: Fri Dec 18, 2020 2:43 pm

Re: HTTP ERROR 599 after upgrade

Post by Fabio »

Actually i'm connected via noip and talking on the 22 port, so i think everything is ok.
Also locally if i try to connect directly with the IP address so 192.168.x.x/owncloud i'm getting the same error.

This is what i'm getting:

Code: Select all

root@DietPi:~# ls -la /var/www/
total 84
drwxr-xr-x  3 root     root      4096 Feb 19 10:44 .
drwxr-xr-x 12 root     root      4096 Dec 18 20:38 ..
-rw-r--r--  1 root     root     37984 Dec 18 20:52 apc.php
-rw-r--r--  1 root     root       216 Jan 11 10:04 index.lighttpd.html
-rw-r--r--  1 root     root     22915 Dec 18 20:52 opcache.php
drwxr-xr-x 13 www-data www-data  4096 Feb 19 10:46 owncloud
-rw-r--r--  1 root     root        20 Dec 18 20:52 phpinfo.php
User avatar
Joulinar
Posts: 5096
Joined: Sat Nov 16, 2019 12:49 am

Re: HTTP ERROR 599 after upgrade

Post by Joulinar »

you are trying to connect from internet or from local network? And I ask to use 192.168.x.x only without onwcloud subfolder. As well pls share status of your database because it's missing within process overview and it doesn't seems to be LISTEN
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply