Asus Tink install stopped working

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
big_g_uk
Posts: 14
Joined: Sun Mar 18, 2018 4:06 pm

Asus Tink install stopped working

Post by big_g_uk » Sun Feb 17, 2019 12:30 am

I logged on to my Asus Tinker that runs DietPi for the first time in a while, and no it won't recognise DietPi commands anymore and errors when trying to run a system update. I could re-install but really don't want to if possible, as I have previously done a fair amount of config.

When I login this is the output, instead of the standard DietPi banner. Also, none of the DietPi commands work anymore
-bash: /DietPi/dietpi/func/dietpi-globals: No such file or directory
-bash: /DietPi/dietpi/login: No such file or directory
apt-get update output -
server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
Err:9 https://deb.debian.org/debian stretch-updates Release

User avatar
MichaIng
Legend
Posts: 1620
Joined: Sat Nov 18, 2017 5:21 pm

Re: Asus Tink install stopped working

Post by MichaIng » Sun Feb 17, 2019 1:28 pm

If you are in mood before resolving the issue (below) to check for the actual reason, do the following:

Code: Select all

systemctl status DietPi.mount # Status of the tmpfs mount
systemctl status dietpi-ramdisk # Status of our RAMdisk service
dmesg # Check for any red error messages, especially related to I/O errors
journalctl # General syslog, very long, might show some additional details compared to dmesg above
It looks like the DietPi-RAMdisk is down. Please do the following:

Code: Select all

ls -Al /DietPi # Verify that this directory is empty
mount /DietPi
df # Check that a "tmpfs ... /DietPi" entry is present
systemctl start dietpi-ramdisk
The above should restore DietPi scripts/code to the RAMdisk. Now logout and login the reload DietPi commands, login banner and such.

big_g_uk
Posts: 14
Joined: Sun Mar 18, 2018 4:06 pm

Re: Asus Tink install stopped working

Post by big_g_uk » Sun Feb 17, 2019 4:05 pm

Many thanks MichaIng

The mount is fine, but errors on ramdisk. The DietPi folder was empty, and after df the DietPi folder was present and empty.

Then it fails to start ramdisk (systemctl start dietpi-ramdisk), journalctl gives a non-descript error and just says exit code.


I think I will just rebuild with newer image now, but thanks for trying.

User avatar
MichaIng
Legend
Posts: 1620
Joined: Sat Nov 18, 2017 5:21 pm

Re: Asus Tink install stopped working

Post by MichaIng » Mon Feb 18, 2019 10:18 am

@big_g_uk
No need to rebuild yet. It's still an uncritical issue ;).

Please see the DietPi-RAMdisk log:
cat /var/tmp/dietpi/logs/dietpi-ramdisk.log

Also try to run it manually to see possible errors and output directly in terminal:
/boot/dietpi/func/dietpi-ramdisk 0

Ah and to make APT work btw, since the reason here most likely is system time being out of sync (due to missing DietPi scripts):
systemctl start systemd-timesyncd

big_g_uk
Posts: 14
Joined: Sun Mar 18, 2018 4:06 pm

Re: Asus Tink install stopped working

Post by big_g_uk » Mon Feb 25, 2019 11:33 pm

Hi,

The output of the first 2 commands are as follows, is it worth me downloading and running the PREP_SYSTEM_FOR_DIETPI.sh?

/bin/bash: /boot/dietpi/dietpi-ramdisk: No such file or directory


/boot/dietpi/func/dietpi-ramdisk 0
-bash: /boot/dietpi/func/dietpi-ramdisk: No such file or directory


Thanks

Post Reply