Allo Piano DAC support

Having issues with your DietPi installation, or, found a bug? Post it here.
Janis
Posts: 28
Joined: Sun Oct 30, 2016 9:42 am

Allo Piano DAC support

Post by Janis » Sun Nov 13, 2016 5:35 pm

Hello,

There is no Soundacrd selctetion for Allo DAC products in config menu.
https://www.allo.com/sparky-eu/piano-dac.html

What should I use, which card/ driver to enable Allo Piano DAC in DietPi?

Janis

Janis
Posts: 28
Joined: Sun Oct 30, 2016 9:42 am

Re: Allo Piano DAC support

Post by Janis » Mon Nov 14, 2016 3:13 pm

Hi,

Just got the driver c code from the also tech support team.
https://github.com/raspberrypi/linux/bl ... iano-dac.c

Please advise how to add it to dietpi?
Shall it be compiled and launched, or somehow embedded in dietpi image?

Need your help to get it done.

Janis

User avatar
Fourdee
Site Admin
Posts: 2789
Joined: Tue Feb 06, 2007 12:36 pm

Re: Allo Piano DAC support

Post by Fourdee » Sun Nov 20, 2016 11:49 am

Hi Janis,

Looks like there is a dtb already available: https://github.com/raspberrypi/firmware ... audio.dtbo

So, should just be a case of adding the following to /DietPi/config.txt:

Code: Select all

dtoverlay=allo-piano-dac-pcm512x-audio
Reboot, then check soundcard exists with:

Code: Select all

aplay -l
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.

Janis
Posts: 28
Joined: Sun Oct 30, 2016 9:42 am

Re: Allo Piano DAC support

Post by Janis » Wed Nov 23, 2016 12:42 pm

Thank you, that worked!

I have now tested Allo DACs - they are amazing. The best sounding DACs I have seen for Raspberry so far. Much better than Audiophonics V3.
Will post my review on Roon Community site.

Janis

User avatar
Fourdee
Site Admin
Posts: 2789
Joined: Tue Feb 06, 2007 12:36 pm

Re: Allo Piano DAC support

Post by Fourdee » Wed Nov 30, 2016 8:17 pm

Janis wrote:Thank you, that worked!

I have now tested Allo DACs - they are amazing. The best sounding DACs I have seen for Raspberry so far. Much better than Audiophonics V3.
Will post my review on Roon Community site.

Janis
Excellent, great to hear :)

I'am still enjoying the JustBoom DAC HAT and Odroid HiFi Shield 2. Do you have either, would be good to get a comparison?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.

Janis
Posts: 28
Joined: Sun Oct 30, 2016 9:42 am

Re: Allo Piano DAC support

Post by Janis » Fri Dec 02, 2016 11:42 am

No unfortunately, I don't have these.
Here is my review of Allo DACs.

https://community.roonlabs.com/t/allo-r ... y-pi/16263

User avatar
Fourdee
Site Admin
Posts: 2789
Joined: Tue Feb 06, 2007 12:36 pm

Re: Allo Piano DAC support

Post by Fourdee » Fri Dec 02, 2016 1:21 pm

Janis wrote:No unfortunately, I don't have these.
Here is my review of Allo DACs.

https://community.roonlabs.com/t/allo-r ... y-pi/16263
Excellent review, thanks for sharing :)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.

User avatar
Fourdee
Site Admin
Posts: 2789
Joined: Tue Feb 06, 2007 12:36 pm

Re: Allo Piano DAC support

Post by Fourdee » Sun Dec 04, 2016 4:32 pm

Added Allo Piano to dietpi-config for v139:
Untitled.png
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.

Janis
Posts: 28
Joined: Sun Oct 30, 2016 9:42 am

Re: Allo Piano DAC support

Post by Janis » Tue Dec 06, 2016 12:14 pm

Thank you!
Will try it.

Do you know why AirPlay has stopped working if on same network are running several Raspberry PIs with Shairport?
http://dietpi.com/phpbb/viewtopic.php?f=11&t=972

Janis
Posts: 28
Joined: Sun Oct 30, 2016 9:42 am

Re: Allo Piano DAC support

Post by Janis » Tue Dec 06, 2016 12:18 pm

I'm not getting v139 update?

Post Reply