Plex - Error installing codec's

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.

Plex - Error installing codec's

Postby leninweblb » Tue May 30, 2017 6:34 pm

Hi, how are you? I have installed Plex with a hard drive, among the movies, audio, images, I have 4K (2160p) content with h.265 format, trueHD audio, when I tried to play some stuff of them I have problems, because Plex couldnt install the new codec that needs to play, I was reading the log files and I saw this:

May 17, 2017 18:46:45.160 [0xeacff400] DEBUG - MDE: Tekno3d Com John Wick 4k Hdr Hevc 10bit Bt2020 Dolby Atmos True Hd Visionplushdr1000: selected media 0 / 9639
May 17, 2017 18:46:45.161 [0xeacff400] DEBUG - Starting a transcode session 365bda53e30e4c33-com-plexapp-android at offset -1.0 (state=3)
May 17, 2017 18:46:45.166 [0xeacff400] INFO - CodecManager: obtaining decoder 'hevc'
May 17, 2017 18:46:45.167 [0xeacff400] DEBUG - Downloading document https://plex.tv/api/codecs/hevc_decoder ... 4154a-1188
May 17, 2017 18:46:45.168 [0xeacff400] DEBUG - HTTP requesting GET https://plex.tv/api/codecs/hevc_decoder ... 4154a-1188
May 17, 2017 18:46:46.977 [0xeacff400] DEBUG - HTTP 404 response from GET https://plex.tv/api/codecs/hevc_decoder ... 4154a-1188
May 17, 2017 18:46:46.977 [0xeacff400] DEBUG - Caching document https://plex.tv/api/codecs/hevc_decoder ... 4154a-1188 as eecfb9dd88b4375f6548288ff36b046f3d376f65
May 17, 2017 18:46:46.978 [0xeacff400] ERROR - downloadContainer: expected MediaContainer element, found Response
May 17, 2017 18:46:46.978 [0xeacff400] ERROR - Codecs: Failed to download XML for codec 'hevc_decoder'
May 17, 2017 18:46:46.990 [0xeacff400] ERROR - Error configuring transcoder: Decoder install failed: hevc

As you can see, Plex couldn't install the codec to play that file, how can I fix that?

If you want to see the complete log, check this plz: https://pastebin.com/SZp3QwRc

Best Regards
Lenin

PD. I have an Odroid C2 installed the last version of DiePi.
leninweblb
 
Posts: 4
Joined: Fri Mar 24, 2017 4:43 pm

Re: Plex - Error installing codec's

Postby Fourdee » Wed May 31, 2017 11:26 am

Hi Lenin,

Thanks for the report, seems a known issue with PMS < 1.5.1. The expected URL for downloading the codec from Plex server, returns a 404 (not found):
https://forums.plex.tv/discussion/268211/http-404-when-downloading-codecs

Which is strange, because our installer will install:
Code: Select all
root@DietPi:~# dpkg -l | grep plex
ii  plexmediaserver-installer      1.5.6.3790-4613ce077-1~jessie           armhf        Plex Media Server for Linux


It may be a bug, specific to the current build, available from http://dev2day.de/pms/ repo, which we use to install PMS. Or, a temp issue with Plex's website.

Not a solution, but as a possible workaround, you can disable transcoding on clients by selecting "Quality: Original".
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
User avatar
Fourdee
Site Admin
 
Posts: 2567
Joined: Tue Feb 06, 2007 12:36 pm

Re: Plex - Error installing codec's

Postby leninweblb » Thu Jun 01, 2017 1:56 pm

Hi Fourdee, thank you very much for the quick reply.
Firstly let me send you the best wishes, thanks for take your time to do this awesome distro.
About the problem in last post, it seems the page is available, the problem could be that the parameters that are sent to that page through GET or POST are incorrect.
If you go to that page you have this error:
Code: Select all
[b]status="Release with version 584154a-1188 not found"[/b]

It seems the parameter "status" doesn't match with any valid value.

In addition, it seems this problem could be fixed with an update of PMS.

In dev2day (http://www.dev2day.de) website shows the way to do an update:
https://www.dev2day.de/typo3/projects/plex-media-server/
Is it correct for DietPI?

Kind Regards
Lenin
leninweblb
 
Posts: 4
Joined: Fri Mar 24, 2017 4:43 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 10 guests