Can't enable logging

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
abecvar
Posts: 1
Joined: Fri Mar 08, 2019 3:29 pm

Can't enable logging

Post by abecvar » Fri Mar 08, 2019 3:32 pm

Hi everyone,

I originally had my logging setup to full logging on my dietpi installation. I changed it to none, then later decided that I want to use the RAM option (#2). When I select it and choose install it appears to install fine, but logging never happens (/var/log files are not being generated or updated). When I check the setup again, logging is set to "none". What could I be missing?

Thanks

User avatar
MichaIng
Site Admin
Posts: 1835
Joined: Sat Nov 18, 2017 5:21 pm

Re: Can't enable logging

Post by MichaIng » Sun Mar 10, 2019 3:03 pm

@abecvar
Which logs are you expecting? The syslog/daemon.log/boot.log and all those are only generated by rsyslog which is not installed when using DietPi-RAMlog.
Instead those logs are available (anyway, regardless of rsyslog) via: journalctl

All software title related logs and some system core logs (apt, btmp, wtmp) should be still in place.

Ah I just found a bug that logging mode stage is shown wrong when DietPi-RAMlog was disabled once and is re-enabled. Will fix this for v6.22. However this is only shown wrong in DietPi-Software, the logging behaviour and active RAMlog should not be affected.

To verify please paste:

Code: Select all

cat /etc/fstab
ls -Al /var/log

Okay I fixed this and also did some other minor enhancements to DietPi-RAMlog install/uninstall code: https://github.com/MichaIng/DietPi/blob ... i-software

Post Reply