How to create a DietPi-VM in Pimox7?

I would like to create a DietPi VM in Pimox7…

I ran the DietPi installer scrit through a minimal Debian 11 VM (EFI) (arm64) in Proxmox7.

The Debian 11 was bootable after installation. The script converted Debian 11 to DietPi 8.15.2 for me,
but the system was no longer (EFI) bootable. I can use the rescue mode of the Debian11 to use the newly created DietPi system
start via a shell, but an EFI boot repair fails.

Would it be possible, since someone from the team adapts the installer scrpit, that ARM64 architecture is taken into account, and that the EFI boot system
is not destroyed. Or can you make an ISO for ARM64 architecture from the EFI PC x86_64 image?

Best regards

Why not using our image and following: How to install DietPi - Docs

Let me see, I found a nice YouTube video recently: Proxmox Templates Part 1/2 - VM TEMPLATE - YouTube

EDIT: Ah, ARM64, okay. Did you select “Generic Device” in the DietPi installer?

no, I had select Raspberry pi , but I will try it with the selecht “Generic Device” .

My Base is a Debian 11 ARM64 (only small install, no desktop) intalled in a EFI-VM
in Pimoxt (not Proxmox) on a Raspberry Pi 4-4GB. I would be use DietPi-VM as basic install for any other projeckts with Pimox on a 8GB-RPi4.

Dietpi 8.15.2 is running as host with Pimox 7. Pimox7 can’t emulte x86/x64 CPUs,
and only user the Host CPU. Seabios will not run only EFI-BIOS will get ready.

maybe this is useful [Tutorial] PVE PiMox7 instalation on RPi 3B+ / 4B

ok, i had try the setting “Generic Device”.
Effect: EFI Boot is ok now (in the menü is “Debian” entry, and Logon is okay.

But first run setup fails : ethernet-adapter no found . :frowning:

Edit: I had corrected the Ethernetsettings in /etc/network/interfaces.

The VM is now runnning fine. Thank you for your help !! :smiley: :+1:

Thank you.
I had problems to install DiePi in arm64 Architektur in a Pimox7-EFI-VM.
DietPi is running as Host for Pimox on RPi4,too.

But it’s fixed now.

The “Raspberry Pi” selection does not work as this assumes that DietPi is to be installed on native RPi hardware rather than within a VM and hence replaces kernel and bootloader with RPi ones while the VM requires GRUB EFI. Generic device is currently the only way for an ARM VM.

I guess the image uses predictable network interface names like enp0s1 or similar, instead of eth0? Our network setup scripts do not yet support those yet. If needed, it could be changed by adding net.ifnames=0 to the GRUB config cmdline entry GRUB_CMDLINE_LINUX or GRUB_CMDLINE_LINUX_DEFAULT and run grub-update afterwards, but no need it it works now.

1 Like

Everything worked fine now, I can now create DietPi VMs under both Debian 11 and Debian 12.

Upgrading from 11 to 12 is also very easy:
sed -i ‘s/bullseye/bookworm/g’ /etc/apt/sources.list
sudo apt update && sudo apt full-upgrade -y

Installing Proxmox 8 on the Raspberry Pi 4 (min. 4GB) in Debian 12 see here (german manual):

I had installed Openmediafault 6 in a Debian11/Dietpi v8.23.3 VM and that also works great.

1 Like

Better use our script for this, which covers some migrations and possible issues: Debian Bookworm has been released – DietPi Blog

EDIT: Oh, lol, just saw the timestamp of your post. I got a notification from this topic today for some reason :smile:.