DietPi on Raspberry Pi first install not working (correctly at least)

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
AlexHuebi
Posts: 3
Joined: Fri Feb 15, 2019 6:37 pm

DietPi on Raspberry Pi first install not working (correctly at least)

Post by AlexHuebi »

To keep it short:
The system is booting, but the 1st-startup update doesn't replace the files needed for the setup to continue.
So the /DietPi/ folder is there but all sub-files/directories are missing.

Because the 1st login works just fine (and also the update sequence is working) am I guessing that the setup deletes the files but has a problem during the pasting of the new ones.

The system is booted and accessable - and the "normal" commands like dietpi-* aren't working.

I can provide logs if needed (but I don't know where those are located).

Edit: Just to be sure (if it wasn't clear yet): This is on a fresh install. No changes made.
User avatar
WarHawk
Posts: 606
Joined: Thu Jul 20, 2017 8:55 am

Re: DietPi on Raspberry Pi first install not working (correctly at least)

Post by WarHawk »

How long are you waiting after first boot..it needs to expand the file to the entire drive..some times it can take a few minutes before it reboots

Also...try wiping and resizing the drive with SD Formatter to ensure your card isn't damaged
AlexHuebi
Posts: 3
Joined: Fri Feb 15, 2019 6:37 pm

Re: DietPi on Raspberry Pi first install not working (correctly at least)

Post by AlexHuebi »

How long are you waiting after first boot
As long as it needs. I wait till the status led is turned off for 1-2 mins.
try wiping and resizing the drive with SD Formatter
did.. didn't help.

But I installed git and tried to clone the repo to the /DietPi/ folder but it didn't let me - not enough space
Cloned it to the home folder - no problem.
User avatar
MichaIng
Site Admin
Posts: 2262
Joined: Sat Nov 18, 2017 6:21 pm

Re: DietPi on Raspberry Pi first install not working (correctly at least)

Post by MichaIng »

File system expansion is done at a very early boot stage before login/SSH is possible, so that should not be an issue.

/DietPi is the Ramdisk location, so obviously dietpi-ramdisk.service did not run successfully.

Please check "journalctl" for systemd boot messages. More particularly "systemctl status dietpi-ramdisk" and "cat /var/tmp/dietpi/logs/dietpi-ramdisk.log" might give some hints.

Also check "dmesg" for possible hardware/firmware errors.
AlexHuebi
Posts: 3
Joined: Fri Feb 15, 2019 6:37 pm

Re: DietPi on Raspberry Pi first install not working (correctly at least)

Post by AlexHuebi »

It seems that the MicroSD I'm using is faulty.
Bought a new one and now its working.

Thanks for the attempts.
This thread can be closed.
Post Reply