Adguard w. Unbound - no name resolution w. local domain

Hello @all

i have installed Dietpi and therefore Adguard Home with Unbound.
Everything regarding Internet DNS is working fine. :smiley:

Unfortunately i can’t connect to my internal clients via DNS (for e.g. http://nucpi.fritz.box:9002/portainer)
because in this case DNS does not work. :frowning:

With Pihole and Unbound this is no problem. I add the the neccessary within Pihole-Settings-DNS-Conditional Forwarding and so on,
and all internal Clients are reachable via DNS. :thinking:

Can anyone advice me how to do this for Adguard/Unbound? In Adguard the field with upstream servers is
greyed out. So no chance anything to do here. Read also many advisories but no luck.

Anyone out there who can help me?

Thank you very much for reading my problems.

Wolle

probably more a question of AGH, if they support Conditional Forwarding like PiHole does. I found an open feature request on AGH GitHub https://github.com/AdguardTeam/AdGuardHome/issues/1622

There is as well a wiki entry https://github.com/AdguardTeam/AdGuardHome/wiki/Configuration#upstreams-for-rdns

If you need to adjust upstream DNS server, have a look into /mnt/dietpi_userdata/adguardhome/dietpi-unbound.conf, as the gui is looked due to the availability of DietPi Unbound config file.

Joulinar,

thanks for your help and input.

I tried several solutions from your post, but still no luck.
This does not work, no matter which solution i tried.

Wolle

maybe you can connect to the AGH GitHub issue and ask the question where to place what configuration

https://github.com/AdguardTeam/AdGuardHome/issues/1622

/edit

finally found the solution in the AGH Wiki:

As you said edit /mnt/dietpi_userdata/adguardhome/dietpi-unbound.conf

make a new entry with your local domain that looks like , e.g

[/fritz.box/]10.1.1.1

save and restart AGH.

After that all your clients are reachable again. But only with FQDN. (server.fritz.box)
Difference to Pihole is, that with AGH you must use FQDN, with Pihole only the servername is ok (server)

But that’s ok. :smiley:

/edit


Joulinar,

thanks again.

This is a good idea, will do this.

Have a good time.

Many regards - Wolfgang

means you have 2 lines inside /mnt/dietpi_userdata/adguardhome/dietpi-unbound.conf now? First line to use unbound and 2nd to use your FritzBox for local DNS resolution. Correct?

Hi,

I am not* sure is this is the same problem I am having or not.

I have homeassistant installed on my RPi which has the name DietPi. To see the interface, I go to http://dietpi:8123

I have just setup AdGuard Home and Unbound and now that link no longer works. I can still get to the interface using the Pi’s IP address http://192.168.1.100:8123

Will the solution to edit dietpi-unbound.conf the right one for me also? Normally, I try things out myself first, but I don’t want to make a mistake that may bring down my network.

Thanks in advance.

[edit: typo*]

hang on, I just added this to the AdGuard DNS rewrites screen and it is working again. I don’t know why I needed to do this, but …yay.

Since the router/DHCP server is not used for DNS resolution anymore, local hostnames need to be setup in AdGuard Home itself, alternatively in Unbound :slight_smile:.

right, but I thought the Pi name was self-advertised, so to speak (mDNS).

It’s also possible to achieve the expansion of hostnames by advertising the domain name (option 15) and the DNS search list (option 119) from the dhcp server.

For mDNS, e.g. Avahi-Daemon needs to be installed.

I thought that was a default install and how Dietpi was broadcasting its name in the first place.

Nope, DietPi is not broadcasting its hostname by default. Usually DHCP servers do so when clients provide their hostname on DHCP lease, probably this is why you thought so?

That makes sense, thanks!

However my router is still my DHCP server so I still don’t understand why moving only DNS to AdGuard should change anything.

Because AGH is doing your DNS resolution now. And AGH don’t know which host name you have on your DHCP server for this device.

You can do conditional forwarding in Pi-hole to send local hostname resolution via router instead of upstream DNS. Not sure whether this can be done in AGH as well? Another approach would be to use the router as upstream in Pi-hole, and a remote upstream DNS with the router.