Cloudshell 2 not working after Upgrade

Upgraded Odroid XU4 Cloudshell 2 to latest Dietpi Bullseye version and Cloudshell LCD and fan do not work any more and SD card stopped booting.
Flashed a new card with Dietpi and Dietpi-software does not have Cloudshell option any more.
How do I reinstall Cloudshell?

the command dietpi-cloudshell is not working for you?

It works and provides the menu but both the LCD and fan do not power up.
I remember installing a few files before and then rebooted and then the LCD would work.
I configured the display to Cloudshell on tty1 and did the autostart then rebooted.
Thanks

@MichaIng can you have a look?

Don’t understand question!
I run dietpi-cloudshell and it runs and I can configure it.

Do you have a installation guide, step by step on how to install on bullseye?
dietpi-config does not have the cloudshell option any more.

It’s part of dietpi-autostart option. (ID 5)

I had gone into autostart and configured it.
dietpi-autostart is configured to root.
Do I?? How do I grant user permissions to run the chosen autostart option?

Does it need to be configured as dietpi?
Thanks!!

Should be fine to have it running as user root

Meant is btw the Odroid CloudShell 2 NAS case with LCD included, which gave the dietpi-cloudshell tool its name, fitting onto that little LCD: https://wiki.odroid.com/accessory/add-on_boards/xu4_cloudshell2/xu4_cloudshell2

I think it’s the same than with the HiFi shields. Drivers are either missing competely or configuration needs to be done quite differently with mainline kernel.

I’ll have a look into the code.

Thanks!
Something is missing as it will not work with the latest version of
DietPi!

Ah, I forgot that Odroid XU4 images are still shipped with vendor kernel, though Armbian builds. Just to be sure, can you show the output of:

uname -a

Also let’s check whether all kernel modules are there:

modprobe -n fbtft_device
modprobe -n spi_s3c64xx

Are CloudShell 1 ans 2 actually using the same (or compatible) LCD? Seeing now it’s SPI, this probably needs to be enabled. I’ll have a look later.

Hi Michalng.

root@Dietpi:~# uname -a
Linux DietXU4 5.4.225-odroidxu4 #22.11.1 SMP PREEMPT Wed Nov 30 10:55:16 UTC 2022 armv7l GNU/Linux
root@Dietpi:~# modprobe -n fbtft_device
modprobe: FATAL: Module fbtft_device not found in directory /lib/modules/5.4.225-odroidxu4
root@Dietpi:~# modprobe -n spi_s3c64xx
root@Dietpi:~#

These are the 3 outputs,
-Scott

Found it:

G_CONFIG_INJECT 'setenv cs2enable' 'setenv cs2enable "true"' /boot/boot.ini
reboot

We need to add this to dietpi-config as dedicated CloudShell 2 LCD option.

I added it before opening the ticket and Cloudshell 2 does not work.

I can not find the Cloudshell 2 option in dietpi-software.
Will you re add it?

it is not a software option to be installed. You should be able to open the config menu using dietpi-cloudshell

@Joulinar
You mix up dietpi-cloudshell tool with Odroid CloudShell 2 NAS case + LCD.

@smac
See the simple command above to have it enabled.

EDIT: Ah you tried that already as it does not work? Nothing shows up on the LCD? Do you have another screen attached concurrently?

@Michalng and @Joulinar

Went back into /boot/boot.ini for the third time and was finally able to change
`‘setenv cs2enable’ ‘setenv cs2enable “true”’

It is working now, now we have to configure it back to normal!
Thanks!!!

DietPi on Odroid XU4 Clamshell 2 working great but the fan.

I took a look at past forum logs and found the below install but it is no longer available!

root@DietXU-4:~# apt-get install odroid-cloudshell cloudshell2-fan
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package odroid-cloudshell
E: Unable to locate package cloudshell2-fan