DietPi does not find modul at gpio

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
AnBad
Posts: 1
Joined: Sat Jan 12, 2019 4:40 pm

DietPi does not find modul at gpio

Post by AnBad »

Hello,

I have hooked up a Modul (EnOcean Pi 868 Gateway (TCM 310 odr TCM_ESP3_0)) at the GPIO, but dietpi will not find it.

What is wrong?

The code

Code: Select all

ls -l /dev/ttyAMA0


should result in:
crw-rw---- 1 root dialout 204, 64 Jun 7 22:56 /dev/ttyAMA0
but only gives this:
ls: cannot access '/dev/ttyAMA0': No such file or directory
and

Code: Select all

ls -l /dev/serial*
should result in this:
lrwxrwxrwx 1 root root 7 Jun 8 18:30 /dev/serial0 -> ttyAMA0
but only gives that back:
ls: cannot access '/dev/serial*': No such file or directory
I guess a libery is missing or some small tweak has to be changed?

Can anybody help me.

The modul is used to transmit enocean homematic protocolls.

Many thanks.
User avatar
MichaIng
Site Admin
Posts: 2421
Joined: Sat Nov 18, 2017 6:21 pm

Re: DietPi does not find modul at gpio

Post by MichaIng »

@AnBad
You need to enable the serial console via:
dietpi-config > Advanced Options > Serial console
AxelRHD
Posts: 3
Joined: Mon Oct 05, 2020 3:23 pm

Re: DietPi does not find modul at gpio

Post by AxelRHD »

I am using a Raspberry 4 with deCONZ RaspBee II having the same issue.

/dev/ttyAMA0 seems not bo be configured correcly giving:

Code: Select all

crw-rw---- 1 root dialout 204, 64 Jun 7 22:56 /dev/ttyAMA0
but giving:

Code: Select all

crw--w---- 1 root tty  204, 64 Okt  8 00:12 /dev/ttyAMA0
I ave enabled ttyAMA0 in the settings, but that has no effect too.

It works on Raspberry3 with Raspian.
User avatar
MichaIng
Site Admin
Posts: 2421
Joined: Sat Nov 18, 2017 6:21 pm

Re: DietPi does not find modul at gpio

Post by MichaIng »

You need to disable the serial console on ttyAMA0 to make it usable for RaspBee. A serial console means there is a login getty waiting for interactive user login via attached serial terminal. In your case you want the port but no login console on it. This also explains why it has tty group permissions ;).

Also assure that Bluetooth is disabled since ttyAMA0 is by default used by Bluetooth on all onboard-WiFi RPi models.
Post Reply