4 (or more) missing modules (webcam)

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
wdt
Posts: 17
Joined: Wed Aug 22, 2018 8:20 am

4 (or more) missing modules (webcam)

Post by wdt »

So, after a bit of struggle (wrong name require) I got motioneye installed
It almost to the point of tearing my hair when found "hwinfo --usb"
3 different web cams,,,, sn9c102,, gspca_stv06xx,,,gspca_zc3xx,, gspca_sonixj
Hard to use motion without a cam
3.10.105-bsp-1.2-ayufan-77
wdt
Posts: 17
Joined: Wed Aug 22, 2018 8:20 am

Re: 4 (or more) missing modules (webcam)

Post by wdt »

After checking all the longsleep and ayufan kernels I see that
they all only have the 2 cam models sold by pine in
....kernel/driver/media/usb/.
My desktop has 125 files, 1.1M in that directory
I guess we have to wait for a mainline?
I certainly am NOT up to learning cross-compiling
and (I may be wrong) most arm boards are a little weak for native compiling
Supposedly the motioneye OS can use webcams,
I guess I will have to check
wdt
Posts: 17
Joined: Wed Aug 22, 2018 8:20 am

Re: 4 (or more) missing modules (webcam)

Post by wdt »

More--
motioneye has the same kernel, longsleep
One of the 2 drivers is uvcvideo, usb video class
This is a standard for windows, since vista, 11 years ago
So, no old webcam will work, only somewhat newer ones, windows compatible
User avatar
WarHawk
Posts: 633
Joined: Thu Jul 20, 2017 8:55 am

Re: 4 (or more) missing modules (webcam)

Post by WarHawk »

V4L should work...you might also have to add user to the video group

Code: Select all

usermod -a -G group user
wdt
Posts: 17
Joined: Wed Aug 22, 2018 8:20 am

Re: 4 (or more) missing modules (webcam)

Post by wdt »

Err...
When you plug in an older usb cam
lsmod -- no sign of any cam module
ls /dev/v* -- no /dev/video0
search for UVC cam or windows8 before purchase
wdt
Posts: 17
Joined: Wed Aug 22, 2018 8:20 am

Re: 4 (or more) missing modules (webcam)

Post by wdt »

By chance a surveillance cam came in the mail today,
after playing with it (on x86 desktop), i checked lsmod, it is a uvc cam
Plugged it into pine64, it worked
Post Reply