PiHole Web Interface is not working

Having issues with your DietPi installation or found a bug? Post it here.
User avatar
Joulinar
Posts: 5934
Joined: Sat Nov 16, 2019 12:49 am

Re: PiHole Web Interface is not working

Post by Joulinar »

yes correct it would be needed to to place the SD card into another Linux box
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Caporeira
Posts: 30
Joined: Sat May 29, 2021 11:21 pm

Re: PiHole Web Interface is not working

Post by Caporeira »

Ok, now problem, please let mi know what i should do when put this sd card to another Linux box ?
User avatar
Joulinar
Posts: 5934
Joined: Sat Nov 16, 2019 12:49 am

Re: PiHole Web Interface is not working

Post by Joulinar »

one card is placed, don't mount it :)
Just check the device name

Code: Select all

lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
one we know the device name, I could give you the command to have it checked.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Caporeira
Posts: 30
Joined: Sat May 29, 2021 11:21 pm

Re: PiHole Web Interface is not working

Post by Caporeira »

Code: Select all

lukas@ubuntu:~$ lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
NAME FSTYPE LABEL  SIZE RO TYPE MOUNTPOINT PARTUUID                             UUID
fd0                1.4M  0 disk                                                 
loop0
     squash       55.4M  1 loop /snap/core                                      
loop1
     squash       65.1M  1 loop /snap/gtk-                                      
loop2
     squash         51M  1 loop /snap/snap                                      
loop3
     squash       32.3M  1 loop /snap/snap                                      
loop4
     squash        219M  1 loop /snap/gnom                                      
sda                 15G  0 disk                                                 
├─sda1
│    vfat          512M  0 part /boot/efi  392ce3ee-01                          0D93-38D7
├─sda2
│                    1K  0 part            392ce3ee-02                          
└─sda5
     ext4         14.5G  0 part /          392ce3ee-05                          666abd6b-cb49-4da5-a642-7856ceef633f
sr0               1024M  0 rom                                                  
sr1               1024M  0 rom                                                  
lukas@ubuntu:~$ 

Code: Select all

root@DESKTOP:~# lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
lsblk: failed to access sysfs directory: /sys/dev/block: No such file or directory
root@DESKTOP:~#
Last edited by Caporeira on Fri Sep 17, 2021 3:30 pm, edited 1 time in total.
User avatar
Joulinar
Posts: 5934
Joined: Sat Nov 16, 2019 12:49 am

Re: PiHole Web Interface is not working

Post by Joulinar »

I don't see the SD card connected to the ubuntu box. Not sure if anything is needed to share USB devices from W10 to ubuntu.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Caporeira
Posts: 30
Joined: Sat May 29, 2021 11:21 pm

Re: PiHole Web Interface is not working

Post by Caporeira »

This looks better :)

Code: Select all

lukas@ubuntu:~$ lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
NAME   FSTYPE   LABEL   SIZE RO TYPE MOUNTPOINT                   PARTUUID                             UUID
loop0  squashfs        55.4M  1 loop /snap/core18/2128                                                 
loop1  squashfs        32.3M  1 loop /snap/snapd/12704                                                 
loop2  squashfs        65.1M  1 loop /snap/gtk-common-themes/1515                                      
loop3  squashfs        32.3M  1 loop /snap/snapd/12883                                                 
loop4  squashfs         219M  1 loop /snap/gnome-3-34-1804/72                                          
loop5  squashfs          51M  1 loop /snap/snap-store/547                                              
sda                    14.9G  0 disk                                                                   
├─sda1 vfat     boot    256M  0 part                              e8af6eb2-01                          DC3E-E470
└─sda2 ext4     rootfs 14.6G  0 part                              e8af6eb2-02                          a7adb26a-8b87-4729-99c8-9f5ac069d51e
sdb                      15G  0 disk                                                                   
├─sdb1 vfat             512M  0 part /boot/efi                    392ce3ee-01                          0D93-38D7
├─sdb2                    1K  0 part                              392ce3ee-02                          
└─sdb5 ext4            14.5G  0 part /                            392ce3ee-05                          666abd6b-cb49-4da5-a642-7856ceef633f
sr0                    1024M  0 rom                                                                    
lukas@ubuntu:~$ 
User avatar
MichaIng
Site Admin
Posts: 3350
Joined: Sat Nov 18, 2017 6:21 pm

Re: PiHole Web Interface is not working

Post by MichaIng »

I didn't read the whole topic but I think the goal is to do an fsck on the RPi SD card, right?

Run:

Code: Select all

# First the boot partition
fsck /dev/sda1
# Then the root partition
fsck -f /dev/sda2
User avatar
Joulinar
Posts: 5934
Joined: Sat Nov 16, 2019 12:49 am

Re: PiHole Web Interface is not working

Post by Joulinar »

@MichaIng

would it need to be dosfsck on sda1 as it is vfat patition. Something like this?

Code: Select all

dosfsck /dev/sda1
fsck -a /dev/sda2
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3350
Joined: Sat Nov 18, 2017 6:21 pm

Re: PiHole Web Interface is not working

Post by MichaIng »

fsck is a wrapper which automatically appends the detected filesystem type, so calls fsck.vfat, which is a symlink to fsck.fat, like dosfsck is. Means fsck can usually be called for every filesystem, at least on Debian. The dosfstools package of course needs to be installed.
Caporeira
Posts: 30
Joined: Sat May 29, 2021 11:21 pm

Re: PiHole Web Interface is not working

Post by Caporeira »

What that's mean ?
My SD card / RPi ist broken or dietpi missing some software?

PS. On another SD card I have installed new dietpi+PiHole. And YouTube on my Android TV was blocked. With filter should I disable ?
Post Reply