Search found 18 matches

by GreenGentleman
Sat Dec 05, 2020 1:15 am
Forum: Troubleshooting
Topic: Unbound not working
Replies: 1
Views: 192

Unbound not working

I recently switched to the dev branch and tried Unbound, but if I install it, I get an error while it tries to restart the service [ OK ] DietPi-Software | Setting in /etc/pihole/setupVars.conf adjusted: PIHOLE_DNS_1=127.0.0.1#5353 [ OK ] DietPi-Software | Setting in /etc/pihole/setupVars.conf adjus...
by GreenGentleman
Thu Nov 12, 2020 2:40 pm
Forum: Troubleshooting
Topic: Permission problems with Mycroft
Replies: 7
Views: 361

Re: Permission problems with Mycroft

A problem might be the recent separation of output devices on RPi, i.e. HDMI and the 3.5mm jack are now different "cards" in ALSA interface which probably means that, when using HDMI for sound output, one must add a separate configuration block for the microphone which is on the 3.5mm car...
by GreenGentleman
Wed Nov 11, 2020 5:38 pm
Forum: Troubleshooting
Topic: Permission problems with Mycroft
Replies: 7
Views: 361

Re: Permission problems with Mycroft

Is there a difference between access to microphone and access to speakers? Since speakers are giving me no problem so far.
by GreenGentleman
Wed Nov 11, 2020 3:56 pm
Forum: Troubleshooting
Topic: Permission problems with Mycroft
Replies: 7
Views: 361

Re: Permission problems with Mycroft

root@DietPi:~# sudo -u mycroft speaker-test speaker-test 1.1.8 Playback device is default Stream parameters are 48000Hz, S16_LE, 1 channels Using 16 octaves of pink noise Rate set to 48000Hz (requested 48000Hz) Buffer size range from 512 to 65536 Period size range from 512 to 65536 Using max buffer...
by GreenGentleman
Wed Nov 11, 2020 3:19 pm
Forum: Troubleshooting
Topic: Permission problems with Mycroft
Replies: 7
Views: 361

Permission problems with Mycroft

Hello again! It seems there are some permission problems with the basic setup of Mycroft on DietPi. Following a basic installation and changing the ownership of the skills folder (according to https://dietpi.com/phpbb/viewtopic.php?p=28464#p28464 ) speaker-test works fine. The mycroft speaker test d...
by GreenGentleman
Mon Nov 09, 2020 11:34 pm
Forum: Troubleshooting
Topic: Owncloud not working after installing Mycroft
Replies: 11
Views: 375

Re: Owncloud not working after installing Mycroft

Could it be that it was moved somewhere else? What's the name of the folder I'm looking for? Will this be fixed if I reinstall Owncloud? Edit: The problem was that I moved the personal folder from my portable HDD to the internal memory. I moved it back, and now everything works. Thanks for your help...
by GreenGentleman
Mon Nov 09, 2020 11:25 pm
Forum: Troubleshooting
Topic: Owncloud not working after installing Mycroft
Replies: 11
Views: 375

Re: Owncloud not working after installing Mycroft

root@DietPi:/# ls -la /mnt/dietpi_userdata/ total 32 drwxr-xr-x 8 root root 4096 Nov 9 15:19 . drwxr-xr-x 8 root root 4096 Nov 9 15:14 .. drwxrwxr-x 2 dietpi dietpi 4096 Nov 9 15:18 Music drwxrwxr-x 2 dietpi dietpi 4096 Nov 9 15:18 Pictures drwxrwxr-x 2 dietpi dietpi 4096 Nov 9 15:18 Video drwxrwxr-...
by GreenGentleman
Mon Nov 09, 2020 11:10 pm
Forum: Troubleshooting
Topic: Owncloud not working after installing Mycroft
Replies: 11
Views: 375

Re: Owncloud not working after installing Mycroft

root@DietPi:/# ls -la /var/log/mysql/ total 0 drwxr-s--- 2 mysql adm 60 Oct 29 16:07 . drwxr-xr-t 10 root root 500 Nov 9 15:14 .. -rw-rw---- 1 mysql adm 0 Nov 9 16:17 error.log root@DietPi:/# ls -la /var/lib/mysql/ ls: cannot access '/var/lib/mysql/': No such file or directory root@DietPi:/# sudo -...
by GreenGentleman
Mon Nov 09, 2020 10:17 pm
Forum: Troubleshooting
Topic: Owncloud not working after installing Mycroft
Replies: 11
Views: 375

Re: Owncloud not working after installing Mycroft

root@DietPi:~# systemctl restart mariadb.service Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details. root@DietPi:~# journalctl -u mariadb -- Logs begin at Thu 2019-02-14 10:11...
by GreenGentleman
Mon Nov 09, 2020 8:27 pm
Forum: Troubleshooting
Topic: Owncloud not working after installing Mycroft
Replies: 11
Views: 375

Re: Owncloud not working after installing Mycroft

root@DietPi:/var/log/mycroft# dietpi-services status [ SUB1 ] DietPi-Services > status [ OK ] DietPi-Services | redis-server active (running) since Mon 2020-11-09 18:11:08 GMT; 1h 15min ago [FAILED] DietPi-Services | ● mariadb.service - MariaDB 10.3.25 database server Loaded: loaded (/lib/systemd/s...