chromium kiosk autostart not working until i install a desktop Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
albone3000
Posts: 6
Joined: Wed Oct 06, 2021 3:02 am

chromium kiosk autostart not working until i install a desktop

Post by albone3000 »

I use dietpi on a few raspberry pis to open a webpage served from my camera server so I can monitor my security cameras. I use dietpi because it loads significantly faster than raspian lite and plays video in chromium from my server much more smoothly.

I recently added a pi3b+ and I couldnt get chromium kiosk autostart to work. It was saying package lsb_release not found. I managed to get that installed and it gave another error I cant recall. Xorg would stop and put me back to a terminal. I ended up getting it to work by installing lxde, I guess that supplied whatever chromium or xorg needed to start in kiosk mode.

Sorry I dont have the exact details I should have taken notes while I was troubleshooting it. I thought Id mention it because if anyone is familiar with the fix Id like to run this pi as lean and mean as possible.
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: chromium kiosk autostart not working until i install a desktop

Post by Joulinar »

Could you share your system details. I would like to replicate it.

Required Information
  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
MichaIng
Site Admin
Posts: 3357
Joined: Sat Nov 18, 2017 6:21 pm

Re: chromium kiosk autostart not working until i install a desktop

Post by MichaIng »

lsb_release shouldn't be necessary, Chromium should start up regardless. Generally a desktop shouldn't be required as long as the X server is installed (it is together with Chromium). But probably we miss some other package depending on the environment. So yes, please share your version details, then we'll try to replicate.
albone3000
Posts: 6
Joined: Wed Oct 06, 2021 3:02 am

Re: chromium kiosk autostart not working until i install a desktop

Post by albone3000 »

Here you go, I did try two different images with the same result, this is the one I ended up installing lxde on to make it work;


cat /boot/dietpi/.version
G_DIETPI_VERSION_CORE=7
G_DIETPI_VERSION_SUB=6
G_DIETPI_VERSION_RC=2
G_GITBRANCH='master'
G_GITOWNER='MichaIng'
G_LIVE_PATCH_STATUS[0]='not applicable'
G_LIVE_PATCH_STATUS[1]='applied'
G_LIVE_PATCH_STATUS[2]='applied'
G_LIVE_PATCH_STATUS[3]='applied'
G_LIVE_PATCH_STATUS[4]='applied'

echo $G_DISTRO_NAME $G_RASPBIAN
bullseye 0

uname -a
Linux ds 5.10.63-v7+ #1457 SMP Tue Sep 28 11:25:31 BST 2021 armv7l GNU/Linux

echo $G_HW_MODEL_NAME
RPi 3 Model B+ (armv7l)
User avatar
MichaIng
Site Admin
Posts: 3357
Joined: Sat Nov 18, 2017 6:21 pm

Re: chromium kiosk autostart not working until i install a desktop

Post by MichaIng »

Here the related GitHub issue, I'm trying to replicate and figure out what's missing if no desktop is installed: https://github.com/MichaIng/DietPi/issues/4782
User avatar
MichaIng
Site Admin
Posts: 3357
Joined: Sat Nov 18, 2017 6:21 pm

Re: chromium kiosk autostart not working until i install a desktop

Post by MichaIng »

Interesting, on ARMv6 at least also installing a desktop does not solve it, but fails with "illegal instructions". You mean the autostart option started working just after you installed LXDE?
EDIT: Ah dedicated known ARMv6 issue I already forgot again. Seems like it's not going to be fixed until more people report a need for Chromium on ARMv6, probably after official Raspberry Pi OS Bullseye release.
User avatar
MichaIng
Site Admin
Posts: 3357
Joined: Sat Nov 18, 2017 6:21 pm

Re: chromium kiosk autostart not working until i install a desktop

Post by MichaIng »

I think I found the missing dependency. Please try:

Code: Select all

apt install libgtk-3-0
To allow startup of Chromium without LXDE (which pulls this library as dependency).
albone3000
Posts: 6
Joined: Wed Oct 06, 2021 3:02 am

Re: chromium kiosk autostart not working until i install a desktop

Post by albone3000 »

MichaIng wrote: Wed Oct 13, 2021 2:52 pm I think I found the missing dependency. Please try:

Code: Select all

apt install libgtk-3-0
To allow startup of Chromium without LXDE (which pulls this library as dependency).
I just started with a fresh image and recreated the problem then installed libgtk-3-0, rebooted and it worked! Thanks!
User avatar
Joulinar
Posts: 5996
Joined: Sat Nov 16, 2019 12:49 am

Re: chromium kiosk autostart not working until i install a desktop

Post by Joulinar »

thx for confirmation.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply