Firmware not Found error after update Topic is solved

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
gobstopper
Posts: 6
Joined: Sun Jul 14, 2019 5:05 pm

Firmware not Found error after update

Post by gobstopper »

I've been running DietPi on a 4GB Pi4 from a USB-connected SSD drive for a number of months and it has been running really well.

I applied some updates this afternoon and found the Pi wasn't reachable over the network following a reboot. When I connected a monitor I found it appeared to stuck on the initial boot screen with the error "Firmware not Found" displayed at the bottom of the screen (see attached).

After some cursing I booted the machine using Raspberry Pi OS from an SD card to confirm the device itself was alive and could see that the USB-connected SSD was still present (now located under /media/pi) so was relieved that whatever had happened hadn't completely lunched the drive. Ran the imager application and used the option to reset the eeprom settings. As soon as I shut down, remove the SD card and tried to boot up again I found myself looking at the same boot error.

Given the process of resetting the eeprom is not reporting any issues, and when I boot from the SD card it is able to see the SSD drive, I wondered if it might be a case of re-copying some boot files to fix the problem?

Has anyone else had the same problem and found a solution that works?

With this Pi currently unable to boot to the SSD running DietPi, I can't use my Nextcloud installation or MariaDB (which is running my Kodi database).

Many thanks in advance.
-Phil.
Attachments
Firmware Error.jpg
gobstopper
Posts: 6
Joined: Sun Jul 14, 2019 5:05 pm

Re: Firmware not Found error after update

Post by gobstopper »

To follow up, I have since managed to install the eeprom tool from Raspberry Pi Imager running on a PC to another SD card and when I boot from that card it comes up with a green screen on the monitor which is apparently confirmation that the eeprom itself is OK.
User avatar
Joulinar
Posts: 4823
Joined: Sat Nov 16, 2019 12:49 am

Re: Firmware not Found error after update

Post by Joulinar »

The issue is not with the eeprom. It's more with the content of the boot partition in your SSD. There seems to be files missing or corrupted. Pls can you boot from SD card and connect your SSD. On the SSD you should have 2 partition. bootFS should be vfat file system and rootFS should be ext4. The important one is the bootFS. Can you share on overview of the content?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
gobstopper
Posts: 6
Joined: Sun Jul 14, 2019 5:05 pm

Re: Firmware not Found error after update

Post by gobstopper »

Many thanks for your quick reply.

I am hoping this shows you what you need to see -

https://www.screencast.com/t/S5oyMWqgzkgK

If it is a matter of creating a new DietPi installation on an SD and copying over some missing files that would be a relief!

As mentioned it was working perfectly until about 4 hours ago.

-Phil
User avatar
Joulinar
Posts: 4823
Joined: Sat Nov 16, 2019 12:49 am

Re: Firmware not Found error after update

Post by Joulinar »

This is all in bootFS? Well you could have a look to the Raspberry OS bootFS. This should show what it should be ;) because DietPi is nothing else than a Raspberry OS in a diet version. You could try to copy the Raspberry OS bootFS to the SSD bootFS
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
gobstopper
Posts: 6
Joined: Sun Jul 14, 2019 5:05 pm

Re: Firmware not Found error after update

Post by gobstopper »

I didn't want to be as bold to assume this (though I had thought that DietPi was Raspbian/Raspberry Pi OS in a "thinner" disguise!)

As you say the /boot folder on my SD card running "Pi OS" contains quite a bit more -

https://www.screencast.com/t/ci3d2CvcTgpD

(there's clearly more but that's all I could fit in one screen grab.)

So, if I were to copy the contents of this folder into /media/pi/boot (which is the boot folder on the USB-attached SSD) I should be good?

I guess there are no guarantees, and given that it is currently broken I can't make it more broken ;)
User avatar
Joulinar
Posts: 4823
Joined: Sat Nov 16, 2019 12:49 am

Re: Firmware not Found error after update

Post by Joulinar »

Just give it a try and copy the data. BootFS didn't contain any live data, they are located on rootFS
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
gobstopper
Posts: 6
Joined: Sun Jul 14, 2019 5:05 pm

Re: Firmware not Found error after update

Post by gobstopper »

Joulinar -

All I can say is THANK YOU!!!

Looks like I'm back up and running after copying the contents of my "Pi OS" /boot folder to the DietPi boot folder on my SSD. Initially Webmin reported that MariaDB wasn't running and I couldn't seem to connect to my Nextcloud URL, but a second reboot fixed that problem.

I can now see in Webmin that MariaDB is running and I can connect to it over PHPMyAdmin and I can also log into Nextcloud again.

*relief*

Thanks again. :)
-Phil.
User avatar
Joulinar
Posts: 4823
Joined: Sat Nov 16, 2019 12:49 am

Re: Firmware not Found error after update

Post by Joulinar »

probably there was a lock file preventing MariaDB to start on first boot and got removed during the 2nd restart. Good it is working now. 8)
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply