Rockpi 4A SSD EX900 not recognized

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
Znik
Posts: 2
Joined: Mon Feb 15, 2021 6:43 pm

Rockpi 4A SSD EX900 not recognized

Post by Znik »

Hello,

on my Rockpi 4A 4GB I installed the Image from download-section (***DietPi_ROCKPi4-ARMv8-Buster.img) on SD-Card.
After first boot the update to Vers. 6.34 went well. All seemed to be in order, but then I noticed that the SSD was missing.
The output from "lsblk" only lists the SD-Card > mmcblk0 <. The SSD is a HP EX900 M.2 500GB, with armbian.img this one
is recognized and working fine, output "lsblk" :
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
mmcblk0 179:0 0 14,5G 0 disk
└─mmcblk0p1 179:1 0 14,3G 0 part /
zram0 252:0 0 1,9G 0 disk [SWAP]
zram1 252:1 0 50M 0 disk /var/log
nvme0n1 259:0 0 465,8G 0 disk
├─nvme0n1p1 259:1 0 31,7G 0 part
└─nvme0n1p2 259:2 0 434,1G 0 part
Could it be, there is a driver, init-script missing or something? Thanks for any help.

*** Yes I know, this Img is for model 4B, but 4A only differs in missing WIFI,BT, otherwise it is the same.
User avatar
Joulinar
Posts: 4830
Joined: Sat Nov 16, 2019 12:49 am

Re: Rockpi 4A SSD EX900 not recognized

Post by Joulinar »

Hi,

not sure if this will change anything but if you like, you can do a test and install an Armbian image. Once this is working and your SSD is detected correctly, try running DietPi PREP script to install DietPi on top. Let's see how it looks afterwards

https://dietpi.com/docs/hardware/#make- ... stribution
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Znik
Posts: 2
Joined: Mon Feb 15, 2021 6:43 pm

Re: Rockpi 4A SSD EX900 not recognized

Post by Znik »

Hello,

thanks for the tip. I will give it a try this weekend, hope the conversion runs properly.
Post Reply