Share of Unofficial DietPi - Radxa Zero 3W

To whom might interested to use DietPi on Radxa Zero 3W, I would like to share the image I just baked! :crazy_face:

The eth0 was not there so you might want to switch it off through dietpi-config during first boot.
The image work for me, do let me know if it works for yours :slightly_smiling_face:


thx for sharing with our community.

Ping @MichaIng FYI

Looks like another reason to try getting a developer sample from Radxa. So far (Zero and Zero 2) I was not successful getting one.

It seems that the radxa zero are quite difficult to get.
I am not their staff but you may try to reach them at

Help please, how do I pre-configure the image for wifi. It will be a headless device. I flashed the image and the normal dietpi-config files were not there.

I just ordered a micro HDMI adapter and USB-C port expander… The image booted and if I can connect a monitor and keyboard…I’m good to go. Thanks for your hard work!!!

I think you may try using the serial debug port with putty to config the board for the first time.

You may go radxa wiki to see how to connect the board. When you could connect through ssh, you should be able to config the wifi through dietpi-config as usual🙂

dietpi-config is a script you have to execute on a running system.
To prepare wifi for first boot you have to modify your dietpi.txt

or flash the image and connect SD card to another Linux box. This should allow to configure dietpi.txt and WiFi settings.

The issue is that the two files I need to configure are not on the SD card after it is flashed with the image file.

I have the bits coming from Amazon today to attach a monitor and keyboard. Hopefully that is all I need to get this board working. Unfortunately, there is not a working CLI image available from Radxa yet. It’s a bit frustrating to have the boards and no software for it. Fingers crossed yours works!!!

You should be able to check available partition and content if you connect the SD card to another Linux box. Maybe you are looking to wrong place :wink:

Hmmm, it booted fine but tells me that the wifi adapter is not available. Any ideas? I’m using a USB network ethernet adapter to get in now. On the bright side, I can SSH in and muck around!

I tried a second board and get the same error…no Wifi HW found.

em… strange. Is that the wifi chip between the HDMI micro port and GPIO is AP6212? and did you see any thing from dmesg | grep wifi?

I get this…
[ 13.659877] [WLAN_RFKILL]: wlan_platdata_parse_dt: wifi_chip_type = ap6212
[ 13.659881] [WLAN_RFKILL]: wlan_platdata_parse_dt: enable wifi power control.
[ 13.659885] [WLAN_RFKILL]: wlan_platdata_parse_dt: wifi power controled by gpio.
[ 13.659937] [WLAN_RFKILL]: wlan_platdata_parse_dt: The ref_wifi_clk not found !
[ 13.659948] [WLAN_RFKILL]: rfkill_set_wifi_bt_power: 1

But, in Diet-Config, it tells me that it doesn’t see any HW.

The HW is there and works. I installed a Radxa image and was able to use the wifi. Unfortunately it is a fat image with a desktop. I told Debian to but into a terminal mode…but the excessive baggage is there. These boards are a work in progress.

I guess the DietPi scripts check only for the onboard wifi devices, there is a $G_HW_ONBOARD_WIFI variable which indicates that. It says also inside dietpi-config

Onboard WiFi

em… interesting, the wifi was actually there and detected.
Would you please try “iw wlan0 scan” and “dmesg | grep wlan0” to see if the wifi interface actually works.
I should had placed the firmware of wifi to the image…

Hi, I get nothing from dmesg | grep wlan0, and iw wlan0 scan just gives me the generic iw usage output (as if the command is typed wrong). Thanks again for all your hard work and help!

Sorry @bitzerjdb I was rather engaged in other tasks recently…
I would take a look at the image.
Maybe the firmware of ap6212 are wrongly linked. Hope I could get it right at once :sweat_smile:

hello @bitzerjdb, I’ve tested a fresh install of image on my board. Upon the first boot, my wifi was detected but I’ve to config the wifi through dietpi-config, it was available but disabled.
After enabling it, I can use scan function to discover the available wifi near me and get connected.

What’s the situation in your case? Could you dump screen of dietpi-config for network options: adapters?
I would be glad if you could upload the full log of dmesg, lsmod for us to study.

They seem to be in stock here: Arace Tech